Sign in with
Sign up | Sign in
Your question
Solved

A Question Regarding Nvidia Drivers

Tags:
Last response: in Graphics & Displays
Share
June 13, 2013 3:41:19 PM

Hello everyone! O/

So I finally bit the bullet and purchased the Gigabyte GTX 770 WindForce OC after a few weeks of tossing and turning between it and the Sapphire Vapor-X HD 7970 GHz Edition 3GB - I finally got fed up of the inconsistent Driver performance with my current setup (PowerColor HD6770s in CrossFire)

I have one final query; I have heard that a small minority of gamers are experiencing performance issues with Nvidia's latest Driver release (320 or something like that?) especially in WoW which is one of my major titles. I am simply curious whether or not this is a major issue or whether it has already been resolved? if not, what Driver version would you recommend?

Thanks,
Conor

Best solution

June 13, 2013 3:47:36 PM

Mate, I had slight problems with the latest drivers. 320.18. I was getting rubbish frame rates on all games, and it basically felt like I wasnt using a GTX 770, but more like something out a box of cereal, if you know what i mean. but it was an easy fix, I simply re downloaded and re installed the drivers (320.18) and now its running like a dream!!

edit: if you still have problems after reinstall 320.18, i would recommend rolling back to 317.14
Share
June 13, 2013 4:04:41 PM

As open to improvement as Nvidia drivers are, they are much better than AMD drivers.
m
0
l
Related resources
June 13, 2013 4:09:40 PM

DanCros said:
Mate, I had slight problems with the latest drivers. 320.18. I was getting rubbish frame rates on all games, and it basically felt like I wasnt using a GTX 770, but more like something out a box of cereal, if you know what i mean. but it was an easy fix, I simply re downloaded and re installed the drivers (320.18) and now its running like a dream!!

edit: if you still have problems after reinstall 320.18, i would recommend rolling back to 317.14


Thanks mate! That is exactly what I was looking for! Cheers

m
0
l
June 13, 2013 4:11:52 PM

Brisingr said:
DanCros said:
Mate, I had slight problems with the latest drivers. 320.18. I was getting rubbish frame rates on all games, and it basically felt like I wasnt using a GTX 770, but more like something out a box of cereal, if you know what i mean. but it was an easy fix, I simply re downloaded and re installed the drivers (320.18) and now its running like a dream!!

edit: if you still have problems after reinstall 320.18, i would recommend rolling back to 317.14


Thanks mate! That is exactly what I was looking for! Cheers



No dramas mate, if you run into any problems, send me a pm!

Dan
m
0
l
!