Sign in with
Sign up | Sign in
Your question

Newly built desktop won't display on monitor

Last response: in Components
Share
June 14, 2013 1:59:15 AM

I just built a new PC:

Corsair 500r
ASRock z77 Extreme 4
i5-3570k w Cooler Master 212+
16 GB Crucial low profile DDR3 1600 RAM
120 GB Kingston SSD
Asus DVD
Radeon HD 7950
CX600 PSU
Asus IPS 23''

All case fan lights are on and the gpu, SSD, and monitor all worked with another computer, but everything else is new. I'm not sure why I can't get a display. This is my first time hooking cables up to a motherboard, though, so maybe I'm missing something. (I tried DVI and HDMI hooked up to my GPU and then just the motherboard, but no luck either way. What should I try next

More about : newly built desktop display monitor

June 14, 2013 2:17:55 AM

Double check cables - ATX 4/8pin to mainboard and 6/8pin power connectors to graphics card.
Try with one only stick of RAM.
Remove the GPU and connect display to motherboard output.
Try starting it up. If it does, go to bios and set primary VGA adpater to PCI-Express.
Insert GPU, test again.
Start addiing more RAM stick first make it 2 than 4.
m
0
l
June 14, 2013 11:37:28 AM

Bejusek said:
Double check cables - ATX 4/8pin to mainboard and 6/8pin power connectors to graphics card.
Try with one only stick of RAM.
Remove the GPU and connect display to motherboard output.
Try starting it up. If it does, go to bios and set primary VGA adpater to PCI-Express.
Insert GPU, test again.
Start addiing more RAM stick first make it 2 than 4.


So far I checked to see if the connectors were in, and they were. Also removed GPU and connected display to motherboard. Still nothing. Next, going to remove a stick of RAM and see if that works. After that, don't really know what to do. I suppose I should experiment with cables and see if there's one I have hooked up that shouldn't be or something.
m
0
l
!