IDE to SATA Adapter problems

Hi, I have an AsRock FM2A55M-DGS Mobo with 6 SATA Ports. I already had one IDE to SATA converter

(like this https://www.google.co.uk/search?hl=en&site=imghp&tbm=isch&source=hp&biw=1280&bih=918&q=ide+to+sats&oq=ide+to+sats&gs_l=img.3..0i10i24.1848.3004.0.3171.11.9.0.2.2.0.93.491.9.9.0...0.0...1ac.1.17.img.z_qGBpcPcEA#facrc=_&imgrc=hE9qQuqsIvUnVM%3A%3BQdLLY5cSOAokqM%3Bhttp%253A%252F%252Fproduct-image.tradeindia.com%252F00196257%252Fb%252F0%252FIDE-to-SATA-Converter.jpg%3Bhttp%253A%252F%252Fwww.ixtreme.net%252Fopen-forum%252F20157-ihas-124b-ide-sata-converter.html%3B436%3B436)

as I didn't want to buy another disk drive and for ages it was working fine. I wanted to stick another HD in my rig as I wanted to back up some stuff so I chose an old IDE HD (as i Don't own any other SATAs) so I bought another adapter (it is identical) The LED lit up but no sign of detection in the BIOS or by Vista so I made sure everything was powered and connected, yes and no luck. I changed the lead, still nothing, changed the adapter and still nothing, in fact neither adapter works now, it seems a bit hit and miss to me! I have tried various jumper setting (CS, Master, Slave) and still no luck. So to sum up neither my DVD-RW nor HDD work, any solutions?

Cheers
1 answer Last reply
More about ide sata adapter problems
  1. In most cases IDE to SATA converter/adapter won't work. I don't know why but this is it. If it's not working don't try hard to make it work, it might damage your MB. It's from my personal experience and opinion.
Ask a new question