Sign in with
Sign up | Sign in
Your question

asrock p67 extreme 6 error code 55. I it dead?

Last response: in Motherboards
Share
June 15, 2013 11:55:25 AM

Hi guys,
I recently bought a p67 extreme 6 to upgrade my pc. I set up everything and when I turned it on it beeped 3 times with the error code '55' I have tried putting in cheap value ram like some forum suggested in the different slots etc but nothing has worked. My bios version is 1.6, would that have anything to do with it? any advice would be greatly appreciated. Thank you.

some of my specs:
cpu: intel i3-2220
RAM: G.skill ripjaw 2x4 gb (listed as supported on website)
graphics: palit nvidia gt 630

June 15, 2013 12:02:00 PM

I forgot to mention that the code '55' means memory is not installed
m
0
l
June 15, 2013 12:03:48 PM

Did you take out one stick of ram and try that? if that doesnt work use the other stick if that dosnt work you're going to have to rma the ram
m
0
l
Related resources
June 15, 2013 12:05:50 PM

Thanks for the suggestion. I have tried one stick of each RAM in each slot but nothing. I have also swapped about the brand new value ram stick in each slot but still getting the error code 55.
m
0
l
June 15, 2013 12:06:35 PM

Sounds like fualty dim slots on the motherboard then, Rma the motherboard :( 
m
0
l
June 15, 2013 12:09:18 PM

:(  I had just bought this brand new on ebay. Well thanks for the help and i hope the seller will help me out on this :/ 
m
0
l
June 15, 2013 12:13:14 PM

Is 1.6 the latest version for your mobo? Do you have or can you borrow a stick from a friend/coworker just to see if that boots? Might also check CPU install
m
0
l
June 15, 2013 12:17:15 PM

no i believe 2. something is the latest one. would a new bios chip help? I had initially got OCZ reaper ram but that didn't work either. I had checked the website and it wasn't supported so i thought that was the reason. So i bought these G.skill ones but still not working. I had also bought a brand new stick of RAM and tried that but still nothing. This is the Ram i had bought : http://www.ebay.co.uk/itm/1GB-RAM-Memory-for-AsRock-P67...
m
0
l
June 15, 2013 12:29:37 PM

Yes because your mobo came out as Sandy Bridge and supported 2nd Gen CPUs, your CPU is a 3rd Gen so it should have been addressed in a BIOS update prior to release...may be your CPU causing the problem
m
0
l
June 15, 2013 12:35:50 PM

So if I installed the latest bios chip it might work? I believe my processor is an ivy bridge but it says that it is supported on the asrock website.
m
0
l
June 15, 2013 12:40:38 PM

yeah but with the new bios which means youll need a sandy bridge cpu to boot and flash the bios then you can switch out with the ivy. The reason this is, is becuase this motherboard came out when sandy bridge cpus were out and was a good option for people who were going to upgrade to ivy when it came out all theyd need to do is flash the bios and install the new cpu instead of getting a new motherboard
m
0
l
June 15, 2013 12:40:59 PM

Yes, that's what i said, you have a 3rd gen CPU (Ivy), and while the mobo does support IB, it didn't originally, you may well not be running a BIOS that supports Ivy Bridge, it came out about a year after Sandy Bridge...do need to flash your BIOS (and it's just program info not a chip),, down load the update from your mobo site and there will be directions on how to 'Flash' the BIOS to the newer version
m
0
l
June 15, 2013 12:43:49 PM

I don't have another cpu accessible at all. So a new chip with the latest bios on would not work you are saying?
m
0
l
!