Sign in with
Sign up | Sign in
Your question

Asus Z87 Hero Rog CSM Boot Device Error - Please help!

Last response: in Motherboards
Share
June 16, 2013 3:04:45 AM

Guys,

I would really appreciate your help if possible with the Asus Hero motherboard.

I put the build all together this morning and the first problem was an error showing "CPU Fan Failure". From reading on the internet this is just because the default bios settings doesn't like the CPU fan's going below 600rpm so I lowered the warning threshold to 400rpm and the error has gone.



The problem I have now is that on booting I get the following error:

"The current BIOS setting do not fully support the boot device. Click OK to enter the BIOS Setup. Press [F1] to enter the BIOS setup.

Go to Advanced > Boot > CSM Parameters, and adjust the CSM (Compatibility Support Module) settings to enable the boot device."


My 2 optical drives show in the bios fine but my 2 hard drives are not being picked up in the bios at all. I have tried changing various settings in the CSM menu but the same error keeps appearing and have also tried altering secure boot to "other os". If I disable CSM I get the following error message:

"The VGA card is not supported by UEFI driver.
CSM (Compatibility Support Module) settings have been changed for better compatibility.
For further adjustments, press [F1] to enter bios setup".


I cannot get past this error or get the bios to register any hard drives installed. I only currently have a Crucial M4 Sata drive connected which I know works as it's from my previous PC - I have disconnected all of the other optical/hard drives.

I have removed my old Geforce 460 card (No money to upgrade this yet) and I'm currently just using the iGPU but this has not helped. I also only have my keyboard and wireless mouse USB dongles connected and no expansion cards are installed.

The weird thing is even with no hard drives/optical drives connected I still get the same error message.

Please help me! I appreciate any advices you can give.

P.S full specs:

CPU: Intel Core i7 4770K Haswell Quad Core CPU Overclocked to 4.6GHz
Motherboard: Asus Z87 Hero ROG (Socket 1150) Motherboard
RAM: TeamGroup Vulcan RED 16GB (2x8GB) DDR3 2133MHz Dual Channel Kit
Cooler: Alpenfohn K2 Mount Doom Premium CPU Cooler
Boot Drive: Crucial RealSSD M4 256GB 2.5" SATA 6Gb/s Solid State Hard Drive (CT256M4SSD2)
Storage Drive: Western Digital Caviar Black 2TB SATA 6Gb/s 64MB Cache - OEM (WD2002FAEX) HDD
PSU: Corsair AX860 Modular
Case: Corsair Carbide Black 500r with 4 X Corsair AF140 fans and 2 X SP120 PWM fans
Fan Controller: BitFenix Recon Black
Optical Drive 1: LiteOn iHas624B
Optical Drive 2: Pioneer BDR-207EBK Blu-Ray Writer
a c 558 V Motherboard
June 16, 2013 10:24:00 AM

Hi,
What happens if you connect only a DVD drive and insert a bootable DVD in it? Does it boot or still the same error message?
m
0
l
June 18, 2013 12:10:29 AM

Bit confused here but looks to me like both my ssd and storage drives have somehow died at the same time when I was building the new PC? I was wearing an anti static wrist thing so not sure what's happened, what is the likelihood of 2 drives dieing at the same time?

I put both drives in my old q6600 comp but they're not picked up in the bios. I have a spare old laptop drive which is a toshiba - Both new & old pc's show this dive in the bios fine and there is no csm error!

I'm going to Rma the ssd today and let you know how it goes.

The problem is now that I've got to get the data off my storage drive but it feels like there's no power when the drive is plugged in. From looking online it might be worth changing the PCB over just to get the data off, have any of you done that before?

Both drives are within warranty but I could really do with my music, photos etc
m
0
l
Related resources
!