Sign in with
Sign up | Sign in
Your question
Solved

Windows 7 doesn't recognize usb sticks plugged in usb 2.0 ports

Tags:
Last response: in Windows 7
Share
June 17, 2013 6:56:21 AM

I bought new motherboard and gpu recently (I've updated my signature) and I decided to do a clean install of Windows 7 Ultimate 64 bit. I encountered a lot of problems during install. I made usb install of my Windows 7 because I don't have dvd drive and I noticed that I can't install it using usb 2.0 because installation freezes. I tried usb 3.0 and it worked, right now I have it installed and configured but I have problems with usb sticks plugged into usb 2.0. All of my 3 usb sticks (Adata S102 pro, Toshiba Asagiri, Goodram Twister) doesn't work with usb 2.0 ports, they work perfectly fine with usb 3.0 though. When I'm plugging them into usb 2.0 I can hear sound that device is plugged in but they show in Explorer only after few minutes from plugging them in. I can't access them because when I'm trying the whole system becomes unresponsive.

I've installed chipset drivers from Gigabyte website and tried to play a bit with bios settings but that didn't help. I thought that usb controller may be damaged but when I installed Windows XP, all of the usb slots (both 2.0 and 3.0) were working properly. Other devices like usb mouse and keyboard also works fine when used in usb 2.0. I was thinking about updating the bios but decided to ask here first. Does anyone have idea what could cause this kind of problems?
a b $ Windows 7
June 17, 2013 8:10:54 AM

XP does not support USB 2 or 3 unless you've installed the usb patch or have SP 2 or SP3 installed. Basically, I doubt that XP whatever would actually support USB 3.0, you probalby just got a compatibility mode to usb 2.0, otherwise, it might be that you only assume to have acheived usb 2 & 3 but actually only getting usb 1.1 speed.

What is your motherboard model number?

Edit - In the bios, you might be able to enable HI-Speed USB option.
June 17, 2013 9:33:32 AM

Speed is not my concern, all I meant is that my usb sticks on Windows 7 works only when plugged into usb 3 and in Windows XP they work fine with both usb 2 and 3. When they are plugged into usb 2 on Windows 7 they don't work at all and they cannot be accessed.

By number you mean revision? Then it's 4.1. I'll check if I have option to enable HI-Speed USB in my bios.
Related resources
a b $ Windows 7
June 17, 2013 11:32:20 AM

http://www.gigabyte.com/products/product-page.aspx?pid=...

I doubt that you are actually accessing USB 3.0, there are not many usb flash drives that are usb 3.0 type.

Toshiba Asagiri - Hi-Speed / Full-Speed USB 2.0 support.
Adata S102 pro - USB 3.0 (compatible with USB 2.0)
Goodram Twisater - USB1.1/USB2.0 Hi-Speed compatible

I think you also have to consider what else you got in your USB ports, having them all occupied can disable some of them, not all usb ports can be accessible unless stated by the manufacturer.
June 17, 2013 1:03:27 PM

I have usb mouse and usb keyboard plugged into usb 2.0 ports. Rest is free and now I can only use my two usb 3.0 ports for my usb sticks because other 2.0 ports doesn't work with them. I've already visited Gigabyte website as I stated in the start post.
a b $ Windows 7
June 17, 2013 6:17:08 PM

When you plug in the usb drives, you have to wait quirte a while for them to be recognized, it just doesn't happen in a few seconds. Some sticks do take as much as a minute before being recognized. If there is no data on the sticks, and you have disabled the option to show files & folders that are empty or blank (including drives) in Folder Options then the drives will not show as being visible.

June 18, 2013 12:16:56 PM

There's data on them and it cannot be accessed because when I click on usb stick, explorer freezes. All 3 sticks are recognized within a second in both usb 2.0 and usb 3.0 ports on Windows XP and data can be accessed.

This is how it looks like after clicking, there's loading bar and whole systems becomes unresponsive, I tried waiting few minutes, nothing happens and bar just keeps feeling:

Desktop screen

It's not hard to guess that this problem cannot be easily fixed, if it would been, I wouldn't even post here.
a b $ Windows 7
June 18, 2013 12:40:07 PM

Is XP on a different Pc or you got dual OS on one PC?

It could be that the format type of the usb sticks are not what is expected for a 64 bit OS, you'd need ex-fat format type whereas a 32 bit Os like XP can recognize fat, fat32 and NTFS formats, however, exfat would not be recognized by XP. Check the format type of each usb drive.
June 20, 2013 7:05:46 AM

I had XP before and now I have installed Windows 7 on the same PC. I tried different formats and it didn't help, sticks works fine with both FAT32 and NTFS in USB 3.0 ports. I think I'll just update my motherboard bios.
a b $ Windows 7
June 20, 2013 7:18:23 AM

In the bios you may need to enable Legacy mode for usb 1.1 to be enabled. If the usb ports are disabled by use of a high speed device then it's due to the Leagacy option not being enabled to allow use of 1.1 versions.
June 22, 2013 1:52:37 PM

USB Legacy is enabled, playing with bios settings doesn't solve this in any way. Tried to install different drivers but still nothing. My usb sticks won't work in usb 2.0, tried to format or change drive letters but disk management freezes when sticks are plugged into usb 2.0.

Goodram Twister plugged into any USB 2.0 port: https://dl.dropboxusercontent.com/u/31084968/2.0.png
Goodram Twister plugged into any USB 3.0 port: https://dl.dropboxusercontent.com/u/31084968/3.0.png
a b $ Windows 7
June 22, 2013 4:25:08 PM

Go into Folder options and uncheck the option to Hide Folders (& Drives) that are empty.

The Goodrem Twister is only 1.1/2.0 compatible, it will only work in the usb port that is 2.0/1.1 compatible.
It might take as long as 90 seconds for windows to recognize the device.

There always seem s to be problems with foreign language Windows, I had to surrender a thread recently due to a Greek Windows 7 issue that I just couldn't resolve, I think I shall surrender this Polish Windows issue, too.

Perhaps it is the defualt language that is at fault as it differs from the System locale ...

Edit - flash memory drives are not supposed to be formaated to NTFS, it's either FAT or FAT32 or EXFAT.
June 23, 2013 2:31:49 AM

It worked on Polish XP just fine and I didn't had to wait 90 seconds for windows to recognize the device.
I tried different format, exFAT as well and it didn't change anything. I believe this is some nasty software/hardware
issue and it will take some time before I'll manage to fix it.
a b $ Windows 7
June 23, 2013 8:51:16 AM

XP is NTFS fat and fat 32 whereas Windows 7 is something a bit different even though you may have formatted to ntfs, Windows 7 x64 requires 32 bit drivers for certain drives, it could be that you don't have those drivers for the ntfs requirement of the flash drives. That sounds a biot far-fetched but what else could it be?

FAT32 - The FAT32 file system was designed as a replacement for the aging FAT16 file system. Windows 95 OSR2, Windows 98 and Windows ME all use FAT32 as a default file system. It supports larger drives more efficiently than FAT16, and is the default file system shipped with most external drives and USB flash drives. It should be noted that the maximum partition size supported is 32GB, with files below 4GB in size.

Compatibility - The NTFS file system is compatible only with Windows NT, 2000, XP and 7. A flash drive formatted using NTFS will only be usable on those systems. FAT32 is an almost universally understood file system that can be read by a wide variety of operating systems. In addition to Windows 95 OSR2, 98 and ME, most versions of Linux and recent versions of Mac OS X can read and write to FAT32.

Considerations - There are disadvantages to formatting a flash drive with NTFS. If permissions are used, the drive may not be accessible even on other Windows systems that support NTFS. The journaling feature that improves the reliability of NTFS also shortens the lifespan of a flash drive because of the additional write overhead, and renders it less efficient for some applications, such as ReadyBoost. Additional steps are required to format a flash drive using NTFS in Windows XP.

Read more: FAT32 Vs. NTFS Flash Drive | eHow http://www.ehow.com/about_5395013_fat-vs-ntfs-flash-dri...


The question I ask is did you format the pen drive using XP or Windows 7?
June 28, 2013 8:38:38 AM

I tried all possible formats that can be used on Windows 7 and still nothing. I formatted all of my sticks on Windows 7, all of the formats (FAT32, FAT, NTFS, exFAT) works on my Windows 7 when sticks are plugged into USB 3.0 port. None of them works when stick are plugged into USB 2.0 port. I'm starting to think that motherboard's usb controller is damaged.

Best solution

a b $ Windows 7
June 28, 2013 1:15:56 PM
Share

Running out of options, it could be that all your usb memory sticks are faulty rather than the ports. Go and buy a new memory stick and try it.
Don't format it and don't delete the pre-installed files on the memory stick (if any). Try it in all of the ports. If a message box appears, write dowen the message and post it.

You may have to go ask a new thread in Storage or Components as this query is not particularily about Windows 7 OS.

If you have used the usb ports for other devices like a pen tablet, usb TV capture device, usb internet, or iphone, sometimes those types of devices reserve that port used as their own. Go check in Device Manager and see if there are any exclamation marks or similar for any of the usb ports.

Also, remove any other usb devices that are not currently required.

Edit - 450 watt PSU is not really good with current rigs, you'd need 620 watt or at least a PSU that provided adequate 5v rail support.
In the days of yore, the motherboard using AT PSU drew its power for all devices from the 5v rail rather than the 12v rail as is common with ATX PSU motherboards of today.

All your issues may actually be caused by the PSU, possibly, and you may need to acquire a better quality PSU.
June 28, 2013 2:29:53 PM

Sticks are fine because I've tested them on a few of different devices and they worked without any kind of problems. If I'll get my hands on some other sticks I'll check them out. I haven't used any other devices in USB 2.0 ports except my keyboard and mouse.

I don't think that there's something wrong with PSU either. I spent hours of stress testing all of my hardware when I bought new GPU and it haven't failed me even once. I even overclocked my hardware to maximum and still haven't encountered any kind of problems, which means that PSU has plenty of backup. Another thing's that I'm using power saving a lot (CPU is idling most of time, same goes for GPU) which results in very small power usage when in idle. I had tested this hardware with my old GPU (9600GT) and I still had problems with USB 2.0 ports on this motherboard. Hovewer I didn't had those problem with old motherboard.

I will still look for a solution but as for now 2 working USB 3.0 have to be enough. Personally I think this is some nasty software problem that could be caused by certain drivers conflicting with each other or just motherboard hardware fault. Either way I'll propably return this motherboard using warranty if I won't find solution because I expect all of the USB ports to work on a new motherboard, regardless of system used.

Anyway, thank you for your time.
a b $ Windows 7
June 28, 2013 4:00:37 PM

Disable power saving mode, that does cause the usb ports to become disabled or use a lower specification.

Thanks for Best Answer but it was not well-deserved. :( 

Just a thought, are youusing anti-virus software?

The issues of today are so far removed from the issues of yester-year, it is difficult to determine exactly what is causing them. Mostly, it's a matter of guessing and hunches rather than any sort of "expertise" or past experience.

I've rebuilt over 45 PC's but they were pre 2003 so not much good to problems of today.

THe GPU: ASUS Radeon 4870 1GB (undervolted & custom fan speeds), that alone could be drawing power from the 5v rail or diverting the power away from USB usage.

I think I may have found some sort of solution, or not, consider it as something to consider..
http://howtofixstuff.blogspot.com.au/2012/01/how-to-fix...

One last thought, do the flash drives light illuminate when you insert them into the ports?

The other alternative, would be to check the motherboard site for any suitable updates.

June 29, 2013 2:16:07 AM

I was talking about pover saving for CPU (AMD Cool&Quiet) and for GPU (Ati Tray Tools profile to underclock, undervolt GPU when in 2D mode) not the Windows one. I'm using Avira but the problem was there when system didn't had antivirus.

I'm 100% sure it's not the GPU, I removed it today and started PC just with onboard graphics and that didn't solve the issue. About your solution, I tried that before and I have updated drivers to the newest version available on the motherboard site.

Flash drives illuminate for a short while only after plugging them in, after that they completely go off, even when system tries to access then.

I noticed one thing though, when I'm plugging the sticks into USB 2.0 ports they show up in Windows Explorer after short while and when I trying to access then, there's loading bar in Explorer and nothing happens (stick is not blinking). But when I'm plugging it off I can see the flash drive content for a second or less. It seems that system is getting access just before completely taking it off from the port.
a b $ Windows 7
June 29, 2013 6:20:32 AM

The usb ports are under-powered, youmay need ot go into bios and enable Hi-Speed option for usb ports, also enable Legacy mode.
Otherwise, you may need to acquire a Hi-Speed USB port hub.

The motherboard requires an 8-pin 12v connector but the PSU only has a 4 pin connector...........!!!!!

Edit -
The video card requires a 6-pin and 8-pin connectors, the PSU only has one 6 pin connector....!!!!!!!
June 29, 2013 11:05:44 AM

I don't have Hi-Speed option in bios. The motherboard requires only one 4 pin connector, second one is only there to help with overclocking (for Bulldozer and Piledriver processors), therefore the motherboard is supposed to work with just one 4 pin connector. Video card requires two 6-pin connectors, the PSU has one but I'm using molex to 6 pin adapter. Furthermore I'm having same problems with old GPU which requires only one 6-pin connecters and with onboard GPU which requires none.
a b $ Windows 7
June 29, 2013 3:37:41 PM

The motherboard requires the whole of the 12v connector not just half a clip.
The mollex on the video card would be coupled woith some other device like the hdd on the same cable line or or fan or whatever.

The old GPU may have had problems with the PSU but only because you only have have the 12v connected.
You can user only half the 12v connection on some motherboards but that will reduce the amount of powe to certain devices and eventually will fry the motherboard chips.
You need to acquire a better PSU, Corsair 620 watt would best suit.


"You can plug a 4 pin 12 volt cable into an 8 pin EPS connector but there's no guarantee that it will work. If the motherboard expects only one 12 volt rail then a 4 pin 12 volt cable may work. If the motherboard expects two 12 volt rails (most dual CPU motherboards require one 12 volt rail per CPU) then it won't work. Even if the motherboard works with a 4 pin 12 volt cable, you are still only providing half of the current carrying capacity which would be provided by an 8 pin EPS cable. That can overheat both the motherboard connector and 4 pin cable. Scorched or melted connectors can be a result. A motherboard which has the 8 pin EPS connector expects a lot of current and you are taking a risk by plugging in a 4 pin cable. The 4 pin cable only fits at one end of the 8 pin EPS motherboard connector so you can't plug it in improperly. If you don't have an 8 pin EPS cable then you can use the adapter. It converts a couple of 4 pin peripheral cables into an 8 pin EPS cable. If you use one of those then be sure to plug the 4 pin peripheral connectors into separate cables coming from the power supply. If you plug them both into the same power supply cable then you are drawing all the power of the EPS connector through a single 18 guage wire. You can often get away with that but there's no reason to do it."
Reference - http://www.tomshardware.com/forum/247660-28-connector
June 29, 2013 4:39:32 PM

That's wrong, 4 pin ATX +12 connector is mainly used to supply power to CPU. Additional 4 pin ATX +12 is used to provide additional 12 volt rails for stable overclocking and for VRMS. It's all about PSU, if it's good enough to provide enough current through one or two rails there's no need to get additional 4 pin ATX connector. So nothing is going to melt or scorch, if hardware is working fine on motherboard which requires one 4 pin ATX +12 (M4A78LT-M LE) then it will be working the same way on motherboard which requires EPS (GA-78LMT-USB3) with just one 4 pin connecter plugged in. There's no magic involved here.

Since I'm building a gaming PC for a mate I borrowed DARK POWER PRO 10 750W which has EPS connecter and provides 30 amps through 12 volt rail. Nothing have changed, stability is the same and USB 2.0 ports still doesn't work.

Anyway the motherboard is going to be returned under warranty.
a b $ Windows 7
July 1, 2013 6:20:20 AM

You've probably fried most of the motherboard usb ports by now so no PSU would make any difference.
July 1, 2013 9:41:09 AM

Yes, I fried only USB 2.0 ports and those fried ports works perfectly fine on Windows XP and Linux.
November 6, 2013 6:42:14 AM

shadovraven said:
Yes, I fried only USB 2.0 ports and those fried ports works perfectly fine on Windows XP and Linux.


Hi. Did You find a solution I have the same problem, driving me crazy.
!