Sign in with
Sign up | Sign in
Your question

AMD Driver has stopped responding: Display Driver has stopped responding and has successfully recovered

Last response: in Graphics & Displays
Share
June 17, 2013 3:05:18 PM

My specs will be at the very end. I have had a total of four graphics cards, AMD Radeon 7750, 7770, 7850, and now the 7950. Every single one of these graphics cards gave me the same issue named as the title. Not until now has it been so extreme, before my screen would go black and go right back to where I was displaying the error. But now, whenever I try to launch ANY game, I get the error. I have tried to change the directory for TdrDelay and no luck, launch Battlefield 3, same error. Minecraft, same error. I have uninstalled and re-installed the drivers so many times it's getting ridiculous. All my system drivers are up to date as well.

OS: Window 7 Ultimate
CPU: I5-3570k
Motherboard: Asrock Z77 extreme 4
Ram: DDR3 3x2gb
GPU: Radeon HD 7950
PSU: CORSAIR GS700 700W
June 17, 2013 3:21:27 PM

Since you have had the issue on multiple cards it needs to be either an OS issue or a hardware issue. The hardware issue would be a bad PCI-e socket.
I can't help much with the OS but what happens if you swap the card to a different PCI-e slot? Does the issue remain? when you uninstalled the drivers did you do a clean install by using the provided AMD program or driver fusion?
June 17, 2013 3:43:02 PM

I will definitely try that; it's going this weird thing were if I plug in my graphics card to my monitor it shows the windows boot logo but when I use onboard graphics it's working like regular...
Related resources :
!