Sign in with
Sign up | Sign in
Your question
Solved

AMD Phenom x4 9650 Processor Incompatible With KN9 Ultra Motherboard?

Last response: in CPUs
Share
June 18, 2013 2:36:17 PM

I'll start off by saying I was sure whether this went in motherboard or CPU, so sorry if this is misplaced. Anyways, I recently obtained and tried to put a (used) AMD Phenom x4 9650 processor into my KN9 Ultra motherboard. I used to have in there (and for now still do) an AMD Athlon 64 X2 Dual-Core processor. AM2+ processor in an AM2 motherboard, not the best but better than what I had. So thermal paste, put it in, put everything back, blah blah blah, all is fine and good until I try turning it on. No spectacular light show or anything, my computer just refuses to boot up. It turns on, lights light up inside as usual, fan is on, but the screen stays blank and there's no indication that its starting up at all. So I try swapping back my old processor. Sure enough, it boots up just as happy as can be, no problems and sparks flying. Swap back to the new one, same result, doesn't boot. So far I've tried to reset the motherboard to no avail, in that it reset fine but my processor still wouldn't work, and that's about all I've been able to find whilst collaborating with my brother on solutions. I've been toying with a BIOS update and I found the page with every one of them, but he says it'd be pointless.

So here lies the final question: Is an AMD Phenom x4 9650 processor incompatible with a KN9 Ultra motherboard? If not, are there any possible solutions? Keep in mind that this is a used processor, so it may simply be old and shot. Any insight at all would be much appreciated, and please let me know if there is any vital information that I left at of which could help in finding a solution!

Best solution

a c 103 à CPUs
a c 86 V Motherboard
June 18, 2013 3:38:48 PM

Abit KN9 Ultra is an old AM2+ motherboard and Phenom support is not supported.

http://www.cpu-upgrade.com/mb-ABIT/KN9_Ultra.html
Share
Related resources
July 5, 2013 6:00:44 PM

Update your bios and clear cmos. I have a similar setup with phenom 9550 and same thing happened before I updated bios.
m
0
l
July 5, 2013 7:05:26 PM

Damien Gates said:
Update your bios and clear cmos. I have a similar setup with phenom 9550 and same thing happened before I updated bios.


I will do that, thank you for your advice.
m
0
l
July 29, 2013 4:39:28 AM

Nataru said:
Damien Gates said:
Update your bios and clear cmos. I have a similar setup with phenom 9550 and same thing happened before I updated bios.


I will do that, thank you for your advice.


Could you please tell me if you managed to make the Phenom x4 cpu run on abit k9nultra mobo? If yes, what bios you used and what other things you did in order to make it work?
Thankyou in advance!
m
0
l
!