Need major help on my new computer build!!!!

Ok so, I just got a build and ive installed everything correctly, even following my motherboards instructions and everything. When I go to plug the power cord into the PSU all my fans flicker and the light on my motherboard flicker as well. The fans twitch. I just bought a new motherboard thinking my old one was dead but obviously not. I even tried having just the cpu ram 24 pin and 8pin connected. Nothing else. And it still is doing this. Ive tried 3 different PSU's. My current one is new. Specs:Asrock extreme4 970. AMD FX 4100. Nvidia gtx 550ti. kingston 8gb ram. 350gb HDD. CoolMax 500watt PSU.
6 answers Last reply
More about major computer build
  1. You might have the motherboard shorted to the case or a mounting screw.
  2. That PSU is complete trash. Coolmax is one of the worst brands for PSUs. That 500w unit likely makes no more than 350w

    Replace it with a unit from Corsair, Seasonic, Antec, XFX.
  3. babernet_1 said:
    You might have the motherboard shorted to the case or a mounting screw.


    I am most certain the motherboard is not fried. because its happened with two motherboards.
  4. It is possible all the PSUs you have tried were trash like the one you have now.
  5. tiny voices said:
    That PSU is complete trash. Coolmax is one of the worst brands for PSUs. That 500w unit likely makes no more than 350w

    Replace it with a unit from Corsair, Seasonic, Antec, XFX.


    Thats what Im going to plan on doing, im gonna go back to microcenter and exchange this one for a corsair.
  6. Problem SOLVED! I jsut bought a new corsaid cx500M Powersupply. The pwoer supply was the problem./
Ask a new question

Read More

Systems