Sign in with
Sign up | Sign in
Your question

Western Digital MyPassport 1TB suddenly stopped working. Windows no longer detects the partitions

Tags:
  • External Storage
  • NTFS
  • Western Digital
  • Partition
  • Storage
  • Formatting Problem
  • Bitlocker
  • External Hard Drive
  • Data Recovery
  • Windows 7
Last response: in Storage
Share
June 22, 2013 2:26:39 AM

I have a 1TB Western Digital MyPassport USB3.0 external hdd. I had two equal sized partitions in it.
Partition 1 was NTFS
Partition 2 was NTFS later changed to Bitlocker

Everything was working fine.
Yesterday I connected it to my Windows 7 laptop as always and was browsing the files. When I tried to open a folder in Partition 1, windows explorer got stuck and went into 'Not responding' state. I waited for some time and then disconnected the HDD from USB port.

From that point on, Windows no longer recognize the Disk when I connect it to USB. The Drive spins up and the LED blinks but the partitions do not appear in Windows explorer. However 'Western digital mypassport' is listed in 'Safely remove hardware' context menu. When I clcik that option, I get the normal 'It is safe to remove the hardware' message as well.

I tried to connect it to other PCs(running Windows 7 and 8) and still it doesn't work.

So far I have done the following checks/diagnostics:

I went into the 'Storage management' tool. The HDD is listed there with the correct size. But it says '931 GB Unallocated'. It also says 'You need to initialize the Disk before you could use it'

As far as I know only new harddisks need to be initialised. Is it possible that Windows deleted my partitions?

I tried a number of data recovery softwares such as EASEUS Data Recovery Wizard, Disk Internals EFS Recovery, Disk Internals NTFS Recovery, Get Data Back... But none of these tools were able to detect the lost partitions.

After these, I ran the Western Digital Diagnotics utility. When I ran the SMART test, it passed without any errors. However the 'Quick Test' failed - although it did not say what the error was exactly. The 'Adavcned scan' got stuck at some point and I had to abort it.

What do you think happened? The HDD is still under warranty and I could get a replacement. But the most important thing is the data. Is there any way I could get the data back? - or atleast part of it?

What are my options?

Thanks in advance

EDIT: EASEUS allows me to take an image of the entire disk. Is it any good. Is there someway I can make use of this image?
Also one of my frineds forwarded me to this forum post:
http://www.diydatarecovery.nl/forum/index.php?PHPSESSID...

That user manged to fix the problem by modifying the header manually. IS it applicable in my case?

More about : western digital mypassport 1tb suddenly stopped working windows longer detects partitions

June 23, 2013 2:33:36 AM

last desperate bump!!

:(  :( 
m
0
l
June 27, 2013 8:09:12 PM

alfredw461 said:
Of course still there is a possibility your restoring all your data from NTFS partition without losing any single file with the help of Remo Recover Windows Free edition which has the ability to recover data in such situations....



I had tried almost every recovery software I could get my hands on. But 50% fo them wont detect the Drive and the otehr 50% fails to do anything. In any case I will give Remo recovery a try this weekend.

Anyway I wrote my own code to read in the first 1000 sectors of the HDD and it retured full of 0s. Later I tried anotehr software and tried to create a mirror of the Disk (only the fisrt 2500 sectors). Same story - full of 0s. So it looks like either the USB cable or the Drive's head is malfunctioning. I have already ordered another USB cable.

However the Drive is not making any strange sounds except it somestimes 'clicks' when I try to do a surface scan(but only once in 2 or 3 minutes or so).

Funny thing is when I ran WD diagnostics tool, it immediately upadted the firmware on the HDD and said everything was succesful. Even now the SMART data indicates Drive is in good shape. Pretty weird.

If the problem is with the Drive heads, is there any possiblity of replacing it? (ofcource WD support has already told me they wont do any repairs and only give me a replacement). I dont want the Disk itself, just the data in it.
m
0
l
November 4, 2013 4:25:24 PM


Hi, i have a WD my book essential 1TB external HDD. Mine is appearing as unallocated in computer management and appearing in device manager but unable to view the data. Windows 7 OS.

Did u manage to find a solution?
Replace the PCB Board?

Let me know!
m
0
l
!