Asus M5a97 LE R2.0 not turning on

Hello Tom's comunity,

I'm not exactly an IT proffesional but I have knowloge about PC assembling, I've bougth the title mother board, after I assemble all components the system just doesn't turn on. I'm not sure what can be happening because I remember several time ago the mobo needs to change a jumper in order to leave it turn on but I tried with the cmos one and nothing happens. When I plug the Power supply the mobo just turn on the led but the power button doesn't work. any recommendation??

Regards!
"Camargo"
4 answers Last reply
More about asus m5a97 turning
  1. If the led is on then the mobo is getting power, which leads me to believe that its not getting enough. How big is your psu and what kind of parts are on the motherboard? (Processor/gpu). I had something similar in which my 500 watt psu died and when the graphics card was removed it ran.
  2. Take the plug on the wires to the power button and reverse the way they are plugged into the mobo
  3. so many thanks! the problem is the power button or the cables, I need to check it. I tried connecting the reset button cables to the power ones and it works.
  4. Fantastic! Glad to be of help
Ask a new question

Read More

Asus Motherboards