Sign in with
Sign up | Sign in
Your question

After overclocking Sapphire 7870XT cannot use 1080p, did I burn the gpu?

Last response: in Graphics & Displays
Share
a b K Overclocking
June 23, 2013 10:58:24 PM

Hey there,

As you can see from the title I am afraid if I have burnt my brand new gpu that I bought this weekend. Let me explain what happened.

Last week my gtx570 went down for some reason and I bought a Sapphire 7870XT with Boost edition. I wasnt really happy about the performance and I read 7870xt can be easily overclocked up to 1250MHz with +20% power offset (as you may know stock core frequency is 925MHz with boost its 975MHz and memory stock frequency is 1500MHz (6000MHz effective)).

So I tried first with 1100MHz and memory clock to 1600MHz with +5% power offset. It was working ok. I ran Unigine Heaven and Valley for some time. It was good enough.

Then I raised the core frequency 1200MHz and memory frequency to 1600MHz with +10% power offset. Ran the same benchmarks and tried playing Crysis3. It was good and I was having like 30-40FPS in Crysis3 but sometimes having a kind of stuttering. So I checked the MSI Afterburner history and found out when the gpu is loaded too much the power wasnt enough and frequency was altered to 925MHZ again. When load drops frequency goes up again along with power.

So basically I was thinking like I should increase the power as it was not enough. Raised to power offset to +12% (from +10%) and voila....

Computer restarts and resolution is broken and only can use only 1600*900 at 60HZ (or lower resolutions). 1080p is not possible to set. I can only use 1080p at 30Hz but its not a native mod and screen is unstable and shaking. So its not a solution.

My monitor is a 23" Samsung LED S23B550V.

Installed drivers which came with CD.
Installed latest drivers.
Installed latest beta drivers.
Installed monitor drivers.
Formatted computer and fresh install of operating system and all drivers.

Nothing helped.

I just cannot run a normal resolution of 1920*1080@60Hz anymore. Do you think the gpu is burnt because of too much power?

Any help is appreciated...
Thanks in advance...
a b K Overclocking
June 25, 2013 1:12:46 AM

Thanks for the info. I actually tried but it didnt really help. So I left it and went for work. Yesterday, when I got back home thinking that I would actually take it to the customer service where I bought it. But then I started the computer to see if I can install older drivers or something...

Voila... It started just fine. Resolution is normal again 1080p@60Hz :) 

I finished the re-installing of all drivers after formatting the system. Ran benchmarks heaven and valley. Overclocked up to 1150Mhz and +9% power with 1175mV (default voltage btw). It ran everything buttery smooth in full details/aa etc...

So I am assuming maybe it needed some time for cooling off lol.
OR
The gpu was designed to scare people off to not to overclock lol... I dunno...

Anyways thanks for the help. For now it runs good. Crysis3 is running smooth over 50fps on high details, 73-74C temps under full load (i guess its a bit high)

For anyone who might have encountered this problem like me... Just let it cool off lol.
Thanks again for reading.
!