Problem with asrock z77 pro 4 motherboard and GeForce gtx 550 ti

Hi I have just upgraded my motherboard and my computer components are:
i3 2120 3.30Ghz
Be quiet 850 psu
2x4 gb ram ddr3 1333
500 gb wd cavier hd
GeForce gtx 550 ti
Asrock Z77 Pro 4 motherboard 1.06 bios
Window 7 64 bit

I have installed the above mother board but when I connect the traffics card to the pcie 3 slot and connect the power, I switch the computer in and my monitor doesn't pick up the signal from my computer. But when I disconnect the traffics card and use the inboard one I have no problems any help would be great please.
5 answers Last reply
More about problem asrock z77 pro motherboard geforce gtx 550
  1. Did you install all the drivers? You gotta download everything and update it from Nvidia website.
  2. It's going to default to on board graphics, use that, load all drivers and switch graphics to your new card in the BIOS
  3. envy14tpe said:
    Did you install all the drivers? You gotta download everything and update it from Nvidia website.


    I have try to install the drivers from the installation disk for the graphics card but when it gets to the last page of the installation it says that it cannot find the component and give me the option to close the installation and that's it.
  4. Tradesman1 said:
    It's going to default to on board graphics, use that, load all drivers and switch graphics to your new card in the BIOS


    I have try to install the drivers from the installation disk for the graphics card but when it gets to the last page of the installation it says that it cannot find the component and give me the option to close the installation and that's it.
    So when I go on the Bios it doesn't even come up mate.
  5. gregoryallen15 said:
    Tradesman1 said:
    It's going to default to on board graphics, use that, load all drivers and switch graphics to your new card in the BIOS


    I have try to install the drivers from the installation disk for the graphics card but when it gets to the last page of the installation it says that it cannot find the component and give me the option to close the installation and that's it.
    So when I go on the Bios it doesn't even come up mate.


    Forget the installation disk. Go to : http://www.geforce.com/drivers/results/62791
    This will give you the latest (non beta) drivers. - 320.18
Ask a new question

Read More

Geforce Computers Connection Motherboards Gtx ASrock