Sign in with
Sign up | Sign in
Your question

Nvidia 680 Artifacts/Problems

Tags:
Last response: in Graphics & Displays
Share
June 27, 2013 2:13:53 PM

Hello all, I am looking for help troubleshooting my 680.

The problem is as follows: In demanding games (Witcher 2, after a few seconds) or after a long time (for example after 1 hour in a movie) I get artifacts (mostly red checkered boxes, but at other times just noise) then the program either dies, or continues running eeeextremely slooooowly and buggy.

This started suddenly 4 days ago.

I have already reverted to older drivers (314 from 320), scanned for viruses, I've already re-seated the card in the slot, and I've already cleaned everything from dust with air-spray.

Card temperature is ~36 degrees idling, can get up to ~45 with no problems, but over 55 degrees I get the artifacts. From other posters, I gather that's a curiously low threshold?

The fan spins at 25%, it doesn't really go over 30% by itself in "automatic" mode. I can set it manually to 100%, but it still overheats FAST to over 55 degrees when playing The Witcher 2, then artifacts, screen turns itself off then back on, then the fan turns back down to 25% by itself.

Most of the time I then go back to a laggy game (without artifacts, but VERY laggy) and I can close it to windows without trouble, but once or twice I had to do a hard restard and found myself with artifacts on the Windows logo screen and then a desktop at 640x480.

Any ideas? Is the card dead or dying?

System details:
Case NZXT Phantom 410 Midi Tower USB
Motherboard Gigabyte GA-Z77X-D3H
UPS 600 Watt Silverstone Strider Net
Processor Intel Core i7-3770K 4x 3.5 Ghz
Video 2048 MB NVIDIA Geforce GTX 680
Sound Onboard Sound
RAM 16384MB DDR3 Corsair XMS 3 Dual
HD 2000 GB SATA III, 7200upm 64MB
Monitor 1 24 inches TFT Iiyama ProLite E2473HDS
Monitor 2 24 inches TFT Iiyama ProLite E2473HS

The system is ~11 months old, the video card is not overclocked to my knowledge.
June 27, 2013 2:47:51 PM

It isn't factory overclocked is it?
m
0
l
June 27, 2013 9:49:03 PM

PyjamasCat said:
It isn't factory overclocked is it?


No...
m
0
l
June 30, 2013 3:20:00 PM

What is the highest you have seen the temps reach? Can you tell me the voltage?
m
0
l
!