Sign in with
Sign up | Sign in
Your question

SLi GTX 660-ti Surround Display Issues

Last response: in Graphics & Displays
Share
June 29, 2013 2:42:49 AM

Hey guys,

I have three screens and two 660-ti cards, I have one monitor plugged in via HDMI to my first card and another DVI into the same card. The second card has a third monitor plugged into and they have the crossfire cable running between them.

The power supply in my rig is a 860w which from my research before purchasing is more than sufficient for powering these two cards.

When I enable the surround display so I can have battlefield 3 running on three screens I get all of screens flickering and then they go black so I have to restart to be able to access my pc again.

I have updated the drivers, re-installed them completely, tried changing where the monitors are plugged in but cannot find the issue.

This surround display worked with just one card so I cannot see a reason why it wouldn't with two cards...

Please can someone advise of what else I can try now

Thanks in advance!

Aaron
a b C Monitor
June 29, 2013 2:53:44 AM

are u really using a CrossFire cable? they are meant for AMD, for nVidia u need SLI
m
0
l
a b C Monitor
June 29, 2013 3:45:56 AM

Have you tried running all the monitors from the primary card?
m
0
l
Related resources
June 29, 2013 11:24:56 PM

jinayhvora said:
are u really using a CrossFire cable? they are meant for AMD, for nVidia u need SLI


Doh! Anyone know where from the UK I can pick one up?
m
0
l
June 29, 2013 11:25:10 PM

Mousemonkey said:
Have you tried running all the monitors from the primary card?


Yes unfortunetly
m
0
l
a b C Monitor
June 30, 2013 5:14:58 AM

Did the bridge come with the motherboard and if so why didn't it fit?
m
0
l
!