Sign in with
Sign up | Sign in
Your question
Solved

Games Run Slow on my brand new rig

Last response: in Video Games
Share
June 30, 2013 11:42:05 PM

I just got a new pc with a AMD FX-8350 processor, a GeForce gtx 660ti (2gb video ram), 16gb ddr3 ram, a 2tb 7200rpm sata 3 hard drive, a 660W power supply, windows 8, and 32 gigs virtual memory on the hard dive. I have checked the system requirements for all of the games i own and my system easily surpasses them yet majority of my games run slow on my computer. Like i mentioned earlier it's a new pc so i doubt doing anything like cleaning my registry of defraging would make a difference. I also doubt it has anything to do with the graphics card since changing video setting in game had no effect on the performance. If anyone could give me some suggestions it would be greatly appreciated.
June 30, 2013 11:50:32 PM

Latest windows 8 updates? what version of graphic driver are you using? what temps do you have on your CPU?
m
0
l
July 1, 2013 12:14:28 AM

I didn't catch a lot of the info you had???? what board was it updated bios wise was the amd drivers updated was windows up to date! that's is the best amd has to offer as of date and its slow? you need to check into what is up to date and whats going on what case did you use power supply fans cooling ect more specs can help us all help you!
Btw a ssd drive as your main then the other drive would make your system scream as others have posted in the past to make a fast booting pc.
m
0
l
Related resources
July 1, 2013 12:15:06 AM

What games? What settings? How many fps?
m
0
l
July 1, 2013 12:22:53 AM

if your games are on the net then you may want to check your internet connection what speed you are getting as well .. cant blame a fast pc for slow bandwith.
m
0
l
July 1, 2013 1:08:14 AM

crisan_tiberiu said:
Latest windows 8 updates? what version of graphic driver are you using? what temps do you have on your CPU?

Graphics and amd drivers are up to date not positive about windows as far as updates. My CPU and GPU temps where normal when I was playing. I was using MSI afterburner to record temps and frame rate, when I tried bf3 on medium setting the frame rate was varying between 80 and 100 fps but the game was lagging and not because of my connection.
m
0
l
July 1, 2013 1:19:36 AM

johnnyb105 said:
I didn't catch a lot of the info you had???? what board was it updated bios wise was the amd drivers updated was windows up to date! that's is the best amd has to offer as of date and its slow? you need to check into what is up to date and whats going on what case did you use power supply fans cooling ect more specs can help us all help you!
Btw a ssd drive as your main then the other drive would make your system scream as others have posted in the past to make a fast booting pc.


This is exactly what i bought:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
m
0
l
July 1, 2013 1:27:05 AM

There is nothing in your system that should hold you back from smooth playing. When you say lagging, why is it that you eliminated the internet connection?

Can you run speedtest.net to show us your internet speeds? Here is an example of mine. The main thing is the ping. If I tether my phone to my computer I get a ping of 50, and I notice lagging, and yet I get 60fps.
This speedtest result was obtained by connecting PC directly with LAN cable.
http://www.speedtest.net/result/2807993220.png
m
0
l
July 1, 2013 9:28:27 AM

envy14tpe said:
There is nothing in your system that should hold you back from smooth playing. When you say lagging, why is it that you eliminated the internet connection?

Can you run speedtest.net to show us your internet speeds? Here is an example of mine. The main thing is the ping. If I tether my phone to my computer I get a ping of 50, and I notice lagging, and yet I get 60fps.
This speedtest result was obtained by connecting PC directly with LAN cable.
http://www.speedtest.net/result/2807993220.png

Even on servers where my ping is 20 i get lag and it lags on single player still

m
0
l
July 1, 2013 9:46:52 AM

ocon87283 said:
envy14tpe said:
There is nothing in your system that should hold you back from smooth playing. When you say lagging, why is it that you eliminated the internet connection?

Can you run speedtest.net to show us your internet speeds? Here is an example of mine. The main thing is the ping. If I tether my phone to my computer I get a ping of 50, and I notice lagging, and yet I get 60fps.
This speedtest result was obtained by connecting PC directly with LAN cable.
http://www.speedtest.net/result/2807993220.png

Even on servers where my ping is 20 i get lag and it lags on single player still


I notice the difference between 10 and 7 ping. If you aren't using wifi then it should be stable.

In single player, if you have lag then there is a real problem in your system. If you are overclocking, don't. Run your system for a day or two at stock. Sometimes we tweak things and sometimes we don't realize how the ripple affects the system.
m
0
l
July 1, 2013 10:41:31 AM

envy14tpe said:
ocon87283 said:
envy14tpe said:
There is nothing in your system that should hold you back from smooth playing. When you say lagging, why is it that you eliminated the internet connection?

Can you run speedtest.net to show us your internet speeds? Here is an example of mine. The main thing is the ping. If I tether my phone to my computer I get a ping of 50, and I notice lagging, and yet I get 60fps.
This speedtest result was obtained by connecting PC directly with LAN cable.
http://www.speedtest.net/result/2807993220.png

Even on servers where my ping is 20 i get lag and it lags on single player still


I notice the difference between 10 and 7 ping. If you aren't using wifi then it should be stable.

In single player, if you have lag then there is a real problem in your system. If you are overclocking, don't. Run your system for a day or two at stock. Sometimes we tweak things and sometimes we don't realize how the ripple affects the system.


I didn't over clock anything I'm wondering if it might be compadibility issues with windows 8 because I've heard people have had a lot of problems w/ that
m
0
l

Best solution

July 1, 2013 9:01:26 PM

Update windows 8 also run a bandwith test like speak easy or something theres a lot of people whom had problems with BF3 and Orgin as well.
Share
March 17, 2014 12:10:59 AM

crisan_tiberiu said:
Latest windows 8 updates? what version of graphic driver are you using? what temps do you have on your CPU?

I mean ive checked for updates on everything. yes I have windows 8, im not sure on the version of the graphics driver but I just downloaded one today. temp readings where at 35C


CORRECTION: woah sorry I thought this was my post, I posted something with the same title lol sorry
m
0
l
!