Sign in with
Sign up | Sign in
Your question
Solved

WD MyBook Essential USB 3.0 Problem

Last response: in Storage
Share
July 1, 2013 1:17:31 AM

I have WD My Book Essential 2TB. The problem is, when i am transferring file via USB 3.0 port, sometimes the harddisk stop working suddenly, as if i unplug the power cable. even the led indicator turned off.

But, if i am transferring file via USB 2.0 port, it work perfectly.

I have friend who have the same harddsik, he has same problem too.

Do you have any idea to solve this problem? Thank you very much...
a b G Storage
July 1, 2013 1:24:39 AM

What motherboard are you using?
m
0
l
July 1, 2013 1:34:39 AM

I had the same problem. Only using the Original drivers from the mainboard manufacture the problem disapeared.
m
0
l
Related resources
July 1, 2013 6:52:24 AM

Madn3ss795 said:
What motherboard are you using?


I'm using Dell Inspiron N4110.
m
0
l
July 1, 2013 6:55:13 AM

dappertje said:
I had the same problem. Only using the Original drivers from the mainboard manufacture the problem disapeared.


if my mainboard driver is the problem, why this problem occurs on my friend who use different notebook vendor too?
m
0
l
a b G Storage
July 1, 2013 6:55:58 PM

So when using this HDD on another usb3.0 device, the problem still happens?
m
0
l
July 2, 2013 2:10:36 AM

Madn3ss795 said:
So when using this HDD on another usb3.0 device, the problem still happens?


yes, it still happen. i've tried it on several device.
m
0
l

Best solution

a b G Storage
July 2, 2013 2:13:18 AM

So it's simply your external HDD that's buggy and you should return it.
Share
August 22, 2013 12:52:15 PM

I got same exact problem! i got me the new asus sabertooth z87 motherboard with C2 stepping because the C1 steeping had the USB 3.0 problems.but iam 100% i got c2 steeping board.when i connect the hard drive with usb 3.0 windows give the disconnect sound for device all the time and it wont be shown as hard drive.on USB 2.0 port every works perfect. i also checked to get newest USB 3.0 driver for the board does not help!
m
0
l
December 7, 2013 5:06:30 AM

I had exactly the same problem.. Its quite easy to fix though

Go to Control Panel -> System and Security -> Power Options

Then Change plan settings on the power plan you are using.

Then Change advanced power settings.

Find USB settings -> USB selective suspend setting and make sure they are on Disabled

I hope this works for you guys as well as it did for me :) 
m
0
l
February 16, 2014 2:28:31 PM

You are God! :)  Thanks mate!
m
0
l
!