Sign in with
Sign up | Sign in
Your question
Solved

Help, cant load Bios! [Solved]

Last response: in Windows 7
Share
July 3, 2013 6:40:10 PM

Hi guys I am a computer noob (Building them that is) and I just built my first computer today. I was trying to install windows 7. I got into BIOS then set it to boot off my Optical drive. I waited a bit, but it didnt load. So I shut it down with the power button at the top of the case. I tried to go into BIOS, but it wouldnt let me! I tried about a dozen more times, but it wouldn't go into BIOS, the boot menu, anything! and it wouldn't load my Windows 7 disc either. I reset the CMOS by using the jumper on my MOBO and removing the Battery. It really sucks and I hope you guys can help me out! Thanks, also here are my specs:
CPU: i5 3570k LGA 2011 with stock cooler
Mobo: Gigabyte Ga z77x up4 th
Ram: 8gb of Corsair vengeance Pro
PSU: Corsair TX750M
Storage: Adata sx900 64gb ssd
and WD caviar black 1tb
GPU: Asus GTX 650 ti Boost
Case: NZXT Phantom 410

Well that pretty much all, thanks in advance!


Update:
I brought my PC to a computer store and they fixed it. The problem was unidentified, but i think it was because my monitor was really old and the new gtx 600 series has problems VGA connections (without drivers). So i just pluged into my TV using HDMI and it worked fine!

P.S i was spamming DEL for a really long time, but it wouldn't let me go into BIOS

Thanks for all the answers!

More about : load bios solved

July 3, 2013 6:44:45 PM

Hi,

When setting up my new system with a gigabyte board, I also had a similar issue. I ended up just plugging into a different USB port.

M
m
0
l

Best solution

a b $ Windows 7
July 3, 2013 6:52:55 PM

Turn computer on and start tapping the DEL key - if it doesn't go in, it may not be seeing the mobo, might try with a different keyboard
Share
a b $ Windows 7
July 3, 2013 6:53:21 PM

Hit F-1 & DEL alternately (back & fourth) during boot.
m
0
l
!