Sign in with
Sign up | Sign in
Your question
Solved

Gigabyte Z87 Ram and USB 3.0 Issue

Last response: in Motherboards
Share
July 5, 2013 9:01:58 AM

A lil help much appreciated.

Installed a GA-Z87X-UD3H board with an i7-4770 CPU a few days ago. I also have a GTX 770 card. I installed all of the drivers on the disc and from the gigabyte MB product website I could find and still have issues.

1- BSOD with 4 sticks of ram. When I use just Channel A, no BSOD. My Ram is from my old board -- G.SKILL Ripjaws X Series 16GB (4 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9Q-16GBXL. I found this suggestion of only using two modules somewhere, but I cannot find that post again. Does anyone know how I can get all 16GB to work with this board?

2- USB 3.0 running at USB 2.0. I have a few USB 3.0 Drives and Card Readers Whenever I insert them into the Blue USB 3.0 ports on the motherboard I get this message: USB 3.0 This device can perform faster
This USB Mass Storage Device can transfer information faster if you connect it to a Super-Speed USB 3.0 port." It seems like I might be missing a driver, but I installed the INTEL INF drivers from the Gigabyte product website and still same issue.

Help please!
a c 478 V Motherboard
July 5, 2013 11:04:10 AM

Try the beta bios that drop says has update for memory. Did you install the hot fix patch that on the mb web page download???
m
0
l
Related resources
a b V Motherboard
July 6, 2013 1:22:52 PM

# Try installing the 4GB module one at a time.
# To check if all the memory modules works alone.
# Reset the CMOS and then install the memory.

Let us know how it turns out.
m
0
l
July 8, 2013 5:04:47 AM

I tried to install the USB 3.0 Hotfix Patch even though it says Windows 8. It would not let me install it. I've not had a chance to putz with the memory. At the moment I am chugging along at 8GB Ram. Obviously I need to get it sorted.
m
0
l

Best solution

November 17, 2013 12:57:19 PM

Did you ever get a fix for your issues? I have the GA-Z87X-D3H (not the UD3H) and am having the same USB issue. Everything runs at 3.0 speed, but the message still comes up. Not just on USB devices either, when a Windows Media Center Extender connects, I get the message too. One day I updated the Intel Chipset drivers and the messages stopped coming up, but another reboot or two later and they came back.

I haven't tried 4 sticks of RAM on this board, but I hope I don't have the same issue. That sounds terrible!
Share
April 21, 2014 7:33:02 PM

Hey guys I'm going to bump this conversation but if you didn't solve the issue I would like you to know that ram companies make special ram for different processers so they have special ram vesions for the new 4th gen intel. Also check the back of the ram and copy what it says then check the bios and make sure the settings are the same. If that don't help be sure your not running ram over 1.55 volts and 1600mhz

Also you may have got a bad batch of motherboards cause my friend had that with his ps4 and so it was always crashing.

Just look at the warranty and send it in asking for a replacement and a second extended warranty for any other problems that could occur they should give the second warranty and if they don't but it breaks again u can ask them to fix it and they probably will
m
0
l
!