Solved

Exception code: 0xc0000005 (Was BEX error code now Appcrash).

Hi guys, not sure where this should go but it is a W7 software issue I suppose. Trying to run FSX SP2 and I'm gettings this error at the start-up splash screen and only on the SP2 update:

Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x03d7dbf4
Faulting process id: 0x1740
Faulting application start time: 0x01ce79c2fd8fa623
Faulting application path: E:\Games\FSX\fsx.exe
Faulting module path: unknown
Report Id: 4b3ddf5f-e5b6-11e2-9bbf-10bf48bac486

I'm a bit consurned as this error is now starting to spread to other games on my system (All getting the 0xc000000005 code).

It was originally a BEX error but after turning off the additional DEP mode on my MB it's turned into the Appcrash, however now my DEP controls are all greyed out. I've tried the following so far:
Drivers/DirectX/.NET/MSV updates and required versions.
Checking O/C'ing settings (ASUS default and optimal settings tried).
File Sharing.
UAC on/off
ChkDsk

My specs are:
O/S: Windows 7 64-bit
CPU: I5-2500k
RAM 16GB
GPU: nVidia GeForce GTX 550 Ti
Soundcard: ASUS D1
All drivers are upto date.

From looking around the web the error is an access error, I've recently installed two new 8GB ram sticks and it was fine until I installed them (The PC didn't have FSX at the time), I've run Memcheck86+ quickly (did one stick twice and all four together once, took 2hours....came up with nothing.) I'm tempted to check the two new RAM sticks to see if they are faulty.

Any help would be great as I'm starting to clutch at straws here.
3 answers Last reply Best Answer
More about exception code 0xc0000005 bex error code appcrash
  1. I ran Memcheck over night on my two new memory sticks, had no errors, swapped them out for my old RAM sticks and still got the c000000005 error..
  2. Best answer
    I've found out the cause appears to be my video drivers for my nVidia 550ti.
    If I reinstall them then the error goes away, but if I reboot to finish the installation (as i've always believed is necessary) the error comes back. I'm at a loss for the cause of this.
  3. to the guy above me, THANK YOU.
Ask a new question

Read More

Windows 7