Catalyst Control Center won't open...

Running the latest and greatest, uninstalled and reinstalled everything and i click it from the start menu, nothing happens. I click it from the task bar, waiting swirly windows 7 circle then nothing. The icon on the task bar lights up then fades away and won't open

Kicker is i used it last week and i never updated it till now because i guess it was out of date

can anyone help? i go nuts if i cant see my temps or control the fans
8 answers Last reply
More about catalyst control center open
  1. try downloading core temp for cpu
  2. my GPU is what i care about most i dont have the money to buy a new one at 500$ haha x.x.. i know without manual fan control my 7970 hits 70c and i dont even like when it goes over 50
  3. maybe a driver cleaner then a full reinstall of the cats from amd something isn't right
  4. i uninstalled it completely even checked the hidden folders, then reinstalled it same thing, really pissing me off actually cause it worked fine a week ago
  5. Does it show up in the task bar? Does task manager show CCC.exe running?
  6. yeah its on my task bar, i click it, it highlights and i get the wait circle, then nothing opens and it unhighlights
  7. I mean does it have a tab on the task bar line an open window?
  8. i fixed it. I thought AMDs full remove uninstall got rid of everything but of course the registry wasnt clean so i cleaned it all and reinstalled and it works now yay
Ask a new question

Read More

Start Menu Catalyst Graphics