Sign in with
Sign up | Sign in
Your question

Odd issue with Rosewill SATA-IDE Adapter only under Windows 7

Last response: in Storage
Share
July 7, 2013 3:56:08 PM

I've recently built a new PC based on the ASRock Z77 Extreme6 motherboard. I've installed Windows 7, and I bought each of these adapters:
Rosewill SATA to IDE:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
SYBA SATA to IDE:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

In Windows 7, the drive when connected to the SYBA shows up just fine. The Rosewill, however, does not seem to work well. The drive shows up in the Disk Management as an unknown drive. The same physical hardware setup, the drive shows up just fine in the BIOS, Windows 7 installer, and in Linux. The same setup, but the drive plugged into the ASMedia SATA controller, works fine (and shows up in Windows 7).

I've got the latest drivers for the Intel chipset. I just find it odd that the only place the Rosewill adapter does not seem to work is in my install of Windows 7. Are there any driver settings that I'm missing?

Regards,
Ryan

Edit: I should note I've tried this with several IDE hard drives with the same outcome. The Rosewill adapter connected to my DVD burner shows up just fine in Win7.
July 8, 2013 8:52:22 PM

Ok, so I've done a bit more research and I've determined it's an issue with drivers under Windows 7.

Here is a quick table of benchmark results for my WD2500JB ATA100 drive
Windows 7
Syba Adapter on Intel SATA: 4MB/s
Rosewill Adapter on Intel SATA: Not detected (shows as unknown device)
Syba Adapter on ASMedia SATA: 55MB/s
Rosewill Adapter on ASMedia SATA: 55MB/s

I should note that the drivers for my Intel SATA showed up as something like "Intel 7x series ..... AHCI SATA" or something similar. I did not have all the ATA Channels (0-5) listed in device manager, only the ASMedia driver, ATA Channel 0 and 1 (for the ASMedia) and the Intel driver.

I booted into Ubuntu 13.04 and used the built in benchmark tool.
Syba Adapter on Intel: 55MB/s
Rosewill Adapter on Intel: 55M/s

At this point, it was becoming clear that my slow Syba and non-detected Rosewill were driver issues in Windows.

This is basically a brand new Win7 install this past weekend.

So, I booted back into windows and uninstalled (and deleted from disk) the driver for the Intel Sata. I rebooted. I should also note, that even though the devices were marked as hot-swappable in the BIOS, I didn't have the Windows menu for ejecting them. After Windows installed the driver and rebooted, things were looking a little more rosy. I now had eject icon for both my drives connected to the intel controller, the device manager showed it was using the "Standard AHCI1.0 Serial ATA Controller", I had double ATA Channels for 0 and 1, and now showed channels 2-5, and with the Rosewill adapter, my drive showed up in My Computer! Success!!..... well, not so fast.

Now both adapters seemed to work, but both still only benchmarked at 4MB/s.

In the properties for ATA Channel 2 (the channel the WD is connected to) it shows UDMA Mode 5 (it's UDMA 5/ATA100 device). However, HD Tune Pro shows that Supported Mode is UDMA 5, and Active mode is UDMA 6.

Any takers on what steps I should take next?

Edit: It's acting as if the drive is in PIO mode, with only 4MB/s read times. But windows indicates it's in UDMA5. This somewhat strange.

Edit 2: I tried installing the latest Intel SATA drivers (which don't really seem to exist) by installing the Intel Rapid Storage Technology program. It's that program that removed all the ATA Channels from the device manager and replaced the standard SATA driver with the Intel 7 Series... driver. Back to using the default Windows SATA drivers and the slow 4MB/s transfer rate. This is a frustrating issue. I may end up nuking Windows and starting over, just to see where that gets me (with my luck, I'll end up two steps back).
m
0
l
!