Sign in with
Sign up | Sign in
Your question
Solved

NICE brand new hardware freezing help!!

Last response: in Components
Share
July 9, 2013 12:58:11 AM

Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....

Best solution

July 9, 2013 1:07:24 AM

Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.
Share
July 9, 2013 1:29:46 AM

I would say that you might have a PSU issue. Did you plug in the PCI-e power connector from the PSU to the GPU? I think it should be a 6 pin PCI-e power connector.

Your PSU make/model doesn't seem like a good one. I'd consider a different one, but could you confirm the make and model of the PSU?
m
0
l
Related resources
July 9, 2013 1:45:02 AM

my money is on the psu being the source of the problem..
m
0
l
July 9, 2013 2:59:01 AM

lunyone said:
I would say that you might have a PSU issue. Did you plug in the PCI-e power connector from the PSU to the GPU? I think it should be a 6 pin PCI-e power connector.

Your PSU make/model doesn't seem like a good one. I'd consider a different one, but could you confirm the make and model of the PSU?

an enermax 750 watt modulated with removable cables

m
0
l
July 9, 2013 3:00:59 AM

Aditec said:

the power supply might be the problem, worth while to try
and borrow a good PSU from someone and run it for some days
and see if something change.
another thing to check is heat.
try to install programs that tell you how hot is your CPU, DISK,CHIPSET,GPU.
as well. open the case and try to touch different heatsink and see if somthing
is so hot that you can not touch it.


i will, thanks. i have excellent temps, and i know thats not the factor. im sure ill figure it out and thanks man. im just freaking out because i spent gobs of cash on this computer. i guess im still not done.

hope it help - good luck.

AdiTec עדיטק מחשבים בחדרה


m
0
l
July 9, 2013 3:07:28 AM

aredflyingbird said:
Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.

actually i looked again and it is an enermax. i almost baught a kantech from amazon but i didnt trust it. when i click the minimize icon on the bottom right hand corner in win 7, i can see my lights go a tiny bit dim every time i click it. i think honestly everyone is right. if tests say everything is good, then it probably is the power supply, i just wish there was a way i could know for a fact but i will try a different one. im beginning to believe that with my high end graphics card and that powerful cpu maby that just dosnt have strong enough rails..... i swear everyone tells me this so if people are telling me then i will do so. if any of you have listings of the top made powersupplys for gamers that arent ridicusuly expensive please let me know. i have gone on google to find one, tiger direct and amazon, just not sure what the ultimate best for the price is. my issue as a computer lover i just dont have testing supplies lol. if its starting to dim lights when i minimize my browser, that is starting to freak me out. i will let everyone know how it goes when i replace it.

m
0
l
July 9, 2013 3:13:52 AM

lunyone said:
I would say that you might have a PSU issue. Did you plug in the PCI-e power connector from the PSU to the GPU? I think it should be a 6 pin PCI-e power connector.

Your PSU make/model doesn't seem like a good one. I'd consider a different one, but could you confirm the make and model of the PSU?

this is too funny lol. literally i get tons of answers like from the whole community that says it is the psu. maby an enermax is a bad choice, it was given to me by a friend and i didnt think it was a big dea. i feel like that power supply is an explosion waiting to happen. i mean it is 750 watts but there could be other factors. i turned off turbo boost so it wouldnt use more resources from it and i even turned of all overclocking features. thank you kindly for your answer man.

m
0
l
July 9, 2013 8:30:21 AM

Justin Collier said:
aredflyingbird said:
Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.

actually i looked again and it is an enermax. i almost baught a kantech from amazon but i didnt trust it. when i click the minimize icon on the bottom right hand corner in win 7, i can see my lights go a tiny bit dim every time i click it. i think honestly everyone is right. if tests say everything is good, then it probably is the power supply, i just wish there was a way i could know for a fact but i will try a different one. im beginning to believe that with my high end graphics card and that powerful cpu maby that just dosnt have strong enough rails..... i swear everyone tells me this so if people are telling me then i will do so. if any of you have listings of the top made powersupplys for gamers that arent ridicusuly expensive please let me know. i have gone on google to find one, tiger direct and amazon, just not sure what the ultimate best for the price is. my issue as a computer lover i just dont have testing supplies lol. if its starting to dim lights when i minimize my browser, that is starting to freak me out. i will let everyone know how it goes when i replace it.



Enermax is usually pretty good, but maybe you have an issue with that one or maybe it's something else. Let us know what your next plan is.
m
0
l
July 11, 2013 6:14:54 AM

lunyone said:
Justin Collier said:
aredflyingbird said:
Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.

actually i looked again and it is an enermax. i almost baught a kantech from amazon but i didnt trust it. when i click the minimize icon on the bottom right hand corner in win 7, i can see my lights go a tiny bit dim every time i click it. i think honestly everyone is right. if tests say everything is good, then it probably is the power supply, i just wish there was a way i could know for a fact but i will try a different one. im beginning to believe that with my high end graphics card and that powerful cpu maby that just dosnt have strong enough rails..... i swear everyone tells me this so if people are telling me then i will do so. if any of you have listings of the top made powersupplys for gamers that arent ridicusuly expensive please let me know. i have gone on google to find one, tiger direct and amazon, just not sure what the ultimate best for the price is. my issue as a computer lover i just dont have testing supplies lol. if its starting to dim lights when i minimize my browser, that is starting to freak me out. i will let everyone know how it goes when i replace it.



Enermax is usually pretty good, but maybe you have an issue with that one or maybe it's something else. Let us know what your next plan is.


i hope someone replies quickly, hence im on amazon now and im hoping for someone to say get this its badass. im looking for modulated psu with pleanty of rails and long cables. i want to individually seperate my cpu fans and gpu signals. i have the h70 core cooler, i wanna put 2 fans on one rail, cd rom on another, my two pcie molex connectors on another so ill never over load them. i think what has actually happened was that since it is a 5 year old psu, i think that over time with all the over clocking i did with my i5 2500k, then going straight to the asus and the 3770k, probably did its job on damaging the rails lol. i think the 3770k is probably what did it because i had it running at over 4,5 ghz and my ram was running at 2400 mhz. i had it all set on extreme loads and high voltage so yea...... u know how it goes. ill check back periodically for some ideas on one. if i get this and it dosnt fix the issue ill also be back to kick ya butts. lol. just a joke

m
0
l
July 15, 2013 6:20:26 AM

lunyone said:
Justin Collier said:
aredflyingbird said:
Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.

actually i looked again and it is an enermax. i almost baught a kantech from amazon but i didnt trust it. when i click the minimize icon on the bottom right hand corner in win 7, i can see my lights go a tiny bit dim every time i click it. i think honestly everyone is right. if tests say everything is good, then it probably is the power supply, i just wish there was a way i could know for a fact but i will try a different one. im beginning to believe that with my high end graphics card and that powerful cpu maby that just dosnt have strong enough rails..... i swear everyone tells me this so if people are telling me then i will do so. if any of you have listings of the top made powersupplys for gamers that arent ridicusuly expensive please let me know. i have gone on google to find one, tiger direct and amazon, just not sure what the ultimate best for the price is. my issue as a computer lover i just dont have testing supplies lol. if its starting to dim lights when i minimize my browser, that is starting to freak me out. i will let everyone know how it goes when i replace it.



Enermax is usually pretty good, but maybe you have an issue with that one or maybe it's something else. Let us know what your next plan is.

hey eveyrone, just thought id send all of u a link to what i just baught im really excited about it.
http://www.amazon.com/gp/product/B0090I9VZI/ref=oh_deta...
just copy and paste the link. i got a corsair hx 750 modular. what do you think about that?
m
0
l
July 15, 2013 2:37:42 PM

Justin Collier said:
lunyone said:
Justin Collier said:
aredflyingbird said:
Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.

actually i looked again and it is an enermax. i almost baught a kantech from amazon but i didnt trust it. when i click the minimize icon on the bottom right hand corner in win 7, i can see my lights go a tiny bit dim every time i click it. i think honestly everyone is right. if tests say everything is good, then it probably is the power supply, i just wish there was a way i could know for a fact but i will try a different one. im beginning to believe that with my high end graphics card and that powerful cpu maby that just dosnt have strong enough rails..... i swear everyone tells me this so if people are telling me then i will do so. if any of you have listings of the top made powersupplys for gamers that arent ridicusuly expensive please let me know. i have gone on google to find one, tiger direct and amazon, just not sure what the ultimate best for the price is. my issue as a computer lover i just dont have testing supplies lol. if its starting to dim lights when i minimize my browser, that is starting to freak me out. i will let everyone know how it goes when i replace it.



Enermax is usually pretty good, but maybe you have an issue with that one or maybe it's something else. Let us know what your next plan is.

hey eveyrone, just thought id send all of u a link to what i just baught im really excited about it.
http://www.amazon.com/gp/product/B0090I9VZI/ref=oh_deta...
just copy and paste the link. i got a corsair hx 750 modular. what do you think about that?


That's pretty overkill, a 560ti would pull around 350 watts on system load. However, if you ever want to get another card for SLI, your covered.
m
0
l
July 18, 2013 11:15:54 AM

aredflyingbird said:
Justin Collier said:
lunyone said:
Justin Collier said:
aredflyingbird said:
Justin Collier said:
Hey everyone, i find myself on here because i have nowhere to turn. My computer hasnt frozen in the last 3 days so i hope i fixed my issue for now, however before it was freezing at idol point and when i always open firefox. i really like that browser, at first i thought i had a ram issue so i replaced it. problem still looms. it restarted when i was in gameplay of simcity. i reinstalled the graphics card driver, download furmark, and u name it, memtest86, and tested every piece of hardware i could think of even testing the clusters of my hard drive but the clusters came back positive of nothing damaged. i have a legal copy of windows. no torrents at all, because im against it now. i wonder if its my psu or GPU. its so hard telling. im puling out my hair and im like a messy cave man now and i feel ten years older because of this. below are my updated system specs.

Motherboard-asus sabertooth p67
gpu-gtx 560ti galaxy
ram- corsair vengence 16 gb
hard drive - 500 gb western digital non oem.
extreemmax 750 wat psu
samsung px2370 syncmaster backlit led monitor
haf 932 gaming advanced case i think 12 bay, not sure.
intel core I73770K unlocked cpu with an h70 core liquid water cooler.

---------------------------------------
THIS IS A PRETTY DAMN GOOD SYSTEM BUT the problem still happens. i unplugged the side fan because the board was reading it at extremely fast rpms.... it was always in the red, and i quit using firefox so now it just hasnt frozen.... WHAT IS MY ISSUE! lol. im going psyco lol. believe it is somewhere along the lines of my psu gpu or cpu.... thanks for taking the time to read, just hope to hear back from you on anything i can try. ive already reformatted. could it be firefox or that fan.....


That power supply you listed isn't reliable, in fact, I've never heard the brand "extreme max". The PSU might not be able to handle your computer on loads. I recommend getting a higher quality one like Corsair/XFX/Seasonic/Antec/NZXT/Silverstone.

actually i looked again and it is an enermax. i almost baught a kantech from amazon but i didnt trust it. when i click the minimize icon on the bottom right hand corner in win 7, i can see my lights go a tiny bit dim every time i click it. i think honestly everyone is right. if tests say everything is good, then it probably is the power supply, i just wish there was a way i could know for a fact but i will try a different one. im beginning to believe that with my high end graphics card and that powerful cpu maby that just dosnt have strong enough rails..... i swear everyone tells me this so if people are telling me then i will do so. if any of you have listings of the top made powersupplys for gamers that arent ridicusuly expensive please let me know. i have gone on google to find one, tiger direct and amazon, just not sure what the ultimate best for the price is. my issue as a computer lover i just dont have testing supplies lol. if its starting to dim lights when i minimize my browser, that is starting to freak me out. i will let everyone know how it goes when i replace it.



Enermax is usually pretty good, but maybe you have an issue with that one or maybe it's something else. Let us know what your next plan is.

hey eveyrone, just thought id send all of u a link to what i just baught im really excited about it.
http://www.amazon.com/gp/product/B0090I9VZI/ref=oh_deta...
just copy and paste the link. i got a corsair hx 750 modular. what do you think about that?


That's pretty overkill, a 560ti would pull around 350 watts on system load. However, if you ever want to get another card for SLI, your covered.

i put it in my computer and im overwhelmed with this product...... and yes it was the damn power supply that is the problem lololololol. so if any one placed bets lets pay up. i got paypal lol. kidding. my only question is, that ive never had to just outright buy a psu before because ive been given them over a number of years. im a little nervous because the fan spinned once when i turned it on.I have read in the instruction manual over night that it is an energey sufficent psu meaning that on underloads it will activate. it spinned when i ran sim city but it stopped. have any of you heard of psus doing that or am i digging myself a death trap? im trusting what ive read. the funny part about all of this is that my leds are almost twice as bright as they were and i havnt frozen in over 72 hours now lol. i get better performance in crysis 3.
m
0
l
July 18, 2013 10:19:40 PM

Excellent PSU! Glad it fixed your problems. It never ceases to amaze me how often the power supply is the culprit when there are problems.
The fan in that PSU will not spin up until the internal temperature of the PSU reaches a certain point, probablly about 35-40degrees C: you probably will never hear it over your case fans and GPU fan.
hope this helps.
m
0
l
!