Sign in with
Sign up | Sign in
Your question

Asrock H61M/U3S3 BIOS Update problem

Last response: in Motherboards
Share
July 9, 2013 10:26:07 AM

Hi, I'm new here and non native english speaker, hope I can explain well :) 

My current spec :
Intel Core i5-2500k
MSI GTX 660ti
8 GB Team Elite DDR3 memory
500 GB WDC Sata3 16mb Caviar Blue
Windows 7 - 32 bit

Plan to getting Ivy Bridge procie, so I learned that I could get Ivy Bridge support for my mobo by updating bios and installing appropriate driver and utility.
I followed the following instruction in Asrock's official web http://www.asrock.com/mb/Intel/H61MU3S3/?cat=FAQ

I got bios successfully updated from v 1.20 to v 1.70.

But then I'm stucks at next following steps :
Step 3: Update suitable Intel HD graphics driver from ASRock website
Tried to install and got error "This computer doesn't meet the minimum requirement for installing the software"

Step 4: Install the correct version of Intel Management Engine from ASRock website
Got error "The setup program failed to start one or more application processes. Setup will exit."

Now about step 5, I managed to install this Intel Smart Connect, but again, in process it required me to switch sata mode to AHCI, by modify registry value then sets sata mode to AHCI from bios.
Should I run computer and leave this AHCI setting as it is? I mean what if I change back the modified registry & switch back the sata mode to IDE in BIOS?
I'm not comfortable with appearance of "safely remove hardware" icon, there may a chance that I eject HDD's accidentally.
In first place I think I dont really need this feature.
In another board like MSI, it took user to simply updating bios to gain IB compatibility.What about Asrock?
May I actually skip these additional steps?
I just need my cheap mobo work normally with new IB procie.

I did Intel Driver Update Utility, and the result, only Chipset INF driver that installed. Other was either unknown or unsupported.
I take it Intel HD graphics and Intel ME driver meant for IGPU, so I cannot install them if got discreet VGA placed at PCIE slot?

Still waiting answer from Asrock Tech Support. Maybe I can get answer from here faster :) 

Edit:
A moment ago I decided to run MSI Live Update 5, scanned system and updated the latest MB driver such as Intel ME and Intel INF driver.
And by my own initiatives, I changed back sata mode from AHCI to IDE, rewrite back registry and reconfigure from BIOS. Nothing bad happen so far.

Edit2:
Nevermind, I decided to order both IB procie and Z77 MB just in case :) 
a b V Motherboard
July 9, 2013 11:51:41 AM

Not sure about your problem but I must ask 8GB's RAM and a 32 bit OS?
July 9, 2013 5:54:56 PM

Yeah, to be specific its 2 pcs of Team Elite Dual channel 4GB(2x2GB) DDR3 , and yes got 32 bit Windows 7 running here.

If there's anything else kindly ask me, I'll do my best to give you information.
!