Solved

Bios hangs at auto-detecting ahci port 0 after BSOD

I recently got a Kernel_data_inpage BSOD on my Asus X83VM notebook. I tried to reboot but I couldn't get past the splash screen. When I tried to get to the BIOS setup, I noticed that the computer would hang at "auto-detecting ahci port 0." After removing the hard drive I would be able to get to the bios setup. When I changed the SATA mode to compatible, I could get past the logo screen but the computer would not detect the hard drive. I tried booting with a boot CD but I still couldn't get past the splash screen if I changed the SATA mode back to enhanced. The hard drive I have is a Seagate Momentus 7200.3. Is there a way to fix the HDD or do I have to get a new one?
2 answers Last reply Best Answer
More about bios hangs auto detecting ahci port bsod
  1. It is dead get a new one seen drives do this before. The controller dies on this drive no repair i am aware of for this failing.

    Thent
  2. Best answer
    I agree. Def dead HD. replace and move on
Ask a new question

Read More

Hard Drives Storage BIOS Blue Screen Port Splash Screen