Sign in with
Sign up | Sign in
Your question

Getting low fps on crysis3/farcry3 with high - end pc

Last response: in Graphics & Displays
Share
July 15, 2013 8:09:45 AM

I7 3930k non-overclocked
GTX 680 TOP overlocked
______________________
FarCry : 16
Crysis : 21
July 15, 2013 8:13:05 AM

Can Boluk said:
I7 3930k non-overclocked
GTX 680 TOP overlocked
______________________
FarCry : 16
Crysis : 21

At what resolution are you running this? Did you max out the MSAA to ridiculous levels? Those are the issues that are probably responsible for the low FPS.
m
0
l
July 15, 2013 8:13:28 AM

RAM? Resolution? PSU? Motherboard?
m
0
l
Related resources
July 15, 2013 8:14:10 AM

How much ram, what power supply, what resolution, and are you using nVidia surround?
m
0
l
July 15, 2013 8:14:14 AM

The Q6660 Inside said:
Can Boluk said:
I7 3930k non-overclocked
GTX 680 TOP overlocked
______________________
FarCry : 16
Crysis : 21

At what resolution are you running this? Did you max out the MSAA to ridiculous levels? Those are the issues that are probably responsible for the low FPS.

1920x1080
x8
my friend has 3770k @ 4.2 with gtx 680 which is not TOP edition, gets 90 with better options then me :( 
m
0
l
July 15, 2013 8:15:55 AM

JRAtk94 said:
RAM? Resolution? PSU? Motherboard?

MB: Rampage 4 Formula
Ram : 16 GB 1600 mhz
PSU 700 watt
I have 3 monitors but only using 1 dont have surround or anything

1920x1080p | 1920x1080p | 1400x900p

m
0
l
July 15, 2013 8:20:08 AM

Well, we just found the problem, it is the MSAA, x8 is ridiculous for a single GTX 680 on 1920x1080. If you want seriously good FPS, try this http://www.guru3d.com/files_details/sweetfx_shader_suit... He must be running multiple GTX 680(s) in SLI. Also, try overclocking your CPU, as it is very useful in tasks wether it be from gaming to productivity.
m
0
l
July 15, 2013 8:21:59 AM

The Q6660 Inside said:
Well, we just found the problem, it is the MSAA, x8 is ridiculous for a single GTX 680 on 1920x1080. If you want seriously good FPS, try this http://www.guru3d.com/files_details/sweetfx_shader_suit... He must be running multiple GTX 680(s) in SLI. Also, try overclocking your CPU, as it is very useful in tasks wether it be from gaming to productivity.

Whenever i overclock my CPU it says overlock failed im just a complete noob at it, but we sitll have a problem he only has 1 680 without top edition and plays at 80,.

MSAA OFF = 31 FPS like REALLY???
m
0
l
July 15, 2013 8:28:03 AM

What is your CPU temp?
m
0
l
July 15, 2013 8:29:39 AM

4745454b said:
What is your CPU temp?


CPU : 58c ingame, %18 usage.
GPU: 60c ingame, %66-72 usage
m
0
l
July 15, 2013 8:29:49 AM

Can Boluk said:
The Q6660 Inside said:
Well, we just found the problem, it is the MSAA, x8 is ridiculous for a single GTX 680 on 1920x1080. If you want seriously good FPS, try this http://www.guru3d.com/files_details/sweetfx_shader_suit... He must be running multiple GTX 680(s) in SLI. Also, try overclocking your CPU, as it is very useful in tasks wether it be from gaming to productivity.

Whenever i overclock my CPU it says overlock failed im just a complete noob at it, but we sitll have a problem he only has 1 680 without top edition and plays at 80,.

MSAA OFF = 31 FPS like REALLY???


Try unplugging your other monitors and see if that helps. Try setting some of the effects to high rather than very high and use the injector I linked. http://www.overclock.net/t/1189242/sandy-bridge-e-overc... Here is an overclocking guide, overclocking can really help you get some more FPS.
m
0
l
July 15, 2013 8:33:24 AM

The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Well, we just found the problem, it is the MSAA, x8 is ridiculous for a single GTX 680 on 1920x1080. If you want seriously good FPS, try this http://www.guru3d.com/files_details/sweetfx_shader_suit... He must be running multiple GTX 680(s) in SLI. Also, try overclocking your CPU, as it is very useful in tasks wether it be from gaming to productivity.

Whenever i overclock my CPU it says overlock failed im just a complete noob at it, but we sitll have a problem he only has 1 680 without top edition and plays at 80,.

MSAA OFF = 31 FPS like REALLY???


Try unplugging your other monitors and see if that helps. Try setting some of the effects to high rather than very high and use the injector I linked.


Unplugged, 26-32 FPS
plugged, 23-30 FPS
Do i really have to do it? cause i got this computer to play @ ultra, my friend evne plays @ ultra but i cant its a problem im trying to solve it not trying to play the game.
m
0
l
July 15, 2013 8:35:45 AM

Your video card is not being fed like it should. Either in data or power. If your cpu isn't getting too hot then a power issue? Is it running at 16x? Some slots on boards are 4x.
m
0
l
July 15, 2013 8:36:36 AM

Started to get 42 FPS at max settings randomly now its again down to 20.....
m
0
l
July 15, 2013 8:37:10 AM

Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Well, we just found the problem, it is the MSAA, x8 is ridiculous for a single GTX 680 on 1920x1080. If you want seriously good FPS, try this http://www.guru3d.com/files_details/sweetfx_shader_suit... He must be running multiple GTX 680(s) in SLI. Also, try overclocking your CPU, as it is very useful in tasks wether it be from gaming to productivity.

Whenever i overclock my CPU it says overlock failed im just a complete noob at it, but we sitll have a problem he only has 1 680 without top edition and plays at 80,.

MSAA OFF = 31 FPS like REALLY???


Try unplugging your other monitors and see if that helps. Try setting some of the effects to high rather than very high and use the injector I linked.


Unplugged, 26-32 FPS
plugged, 23-30 FPS


Alright, it cannot be the monitors. Use the injector and tone down some of the settings to high or run it all @High, you were running settings intended for a Dual GPU setup, your friend must have been running it a lower resolution to get such high FPS.
m
0
l
July 15, 2013 8:38:30 AM

4745454b said:
Your video card is not being fed like it should. Either in data or power. If your cpu isn't getting too hot then a power issue? Is it running at 16x? Some slots on boards are 4x.


How should i check? Should i buy anything or what cause i cant buy anything at the moment .And i remember playing this games with i mean 60-70 FPS
m
0
l
July 15, 2013 8:39:46 AM

The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Well, we just found the problem, it is the MSAA, x8 is ridiculous for a single GTX 680 on 1920x1080. If you want seriously good FPS, try this http://www.guru3d.com/files_details/sweetfx_shader_suit... He must be running multiple GTX 680(s) in SLI. Also, try overclocking your CPU, as it is very useful in tasks wether it be from gaming to productivity.

Whenever i overclock my CPU it says overlock failed im just a complete noob at it, but we sitll have a problem he only has 1 680 without top edition and plays at 80,.

MSAA OFF = 31 FPS like REALLY???


Try unplugging your other monitors and see if that helps. Try setting some of the effects to high rather than very high and use the injector I linked.


Unplugged, 26-32 FPS
plugged, 23-30 FPS


Alright, it cannot be the monitors. Use the injector and tone down some of the settings to high or run it all @High, you were running settings intended for a Dual GPU setup, your friend must have been running it a lower resolution to get such high FPS.

Its a hardware or software problem, hes playing at 1080p with no lag at max settings, and these settings i got it from nvidia experience :) 

m
0
l
July 15, 2013 8:40:27 AM

Use the Red PCI-E slots on the Rampage 4 Extreme to achieve maximum performance. If you do not have a good cooler to overclock, http://www.amazon.com/dp/B00631QFG8 this will work wonders. Run SweetFX, turn of MSAA and run most of the settings @High (Not Very High) and see how it goes. Just remember to Overclock. To check you open the case up and check if the GTX 680 is connected to a red slot.
m
0
l
July 15, 2013 8:41:50 AM

CPUz or gpuz should be able to tell you the slot. Or read the manual.
m
0
l
July 15, 2013 8:44:04 AM

The Q6660 Inside said:
Use the Red PCI-E slots on the Rampage 4 Extreme to achieve maximum performance. If you do not have a good cooler to overclock, http://www.amazon.com/dp/B00631QFG8 this will work wonders.


i have a really really good air cooler, but i just dont know how to overclock :p 
it is on the red slot
m
0
l
July 15, 2013 8:47:30 AM

Can Boluk said:
The Q6660 Inside said:
Use the Red PCI-E slots on the Rampage 4 Extreme to achieve maximum performance. If you do not have a good cooler to overclock, http://www.amazon.com/dp/B00631QFG8 this will work wonders.


i have a really really good air cooler, but i just dont know how to overclock :p 
it is on the red slot


http://www.overclock.net/t/1189242/sandy-bridge-e-overc... That looks like some sort of Zalman CNPS9900 type cooler, am I correct? Also, that PSU looks shaky, http://www.newegg.com/Product/Product.aspx?Item=N82E168... this will help you A LOT.
m
0
l
July 15, 2013 8:50:14 AM

All the info on CPU-Z and GPU-Z
m
0
l
July 15, 2013 8:54:19 AM

The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Use the Red PCI-E slots on the Rampage 4 Extreme to achieve maximum performance. If you do not have a good cooler to overclock, http://www.amazon.com/dp/B00631QFG8 this will work wonders.


i have a really really good air cooler, but i just dont know how to overclock :p 
it is on the red slot


http://www.overclock.net/t/1189242/sandy-bridge-e-overc... That looks like some sort of Zalman CNPS9900 type cooler, am I correct? Also, that PSU looks shaky, http://www.newegg.com/Product/Product.aspx?Item=N82E168... this will help you A LOT.

its
zalman cnps x12
but i cant do aynthing about PSU since i dont have any money left.
m
0
l
July 15, 2013 8:56:06 AM

Can Boluk said:
All the info on CPU-Z and GPU-Z


It says it is running @2.0 X16@X8, that seems odd. I think it had something to do with early drivers, try updating your video card drivers at nVdia's website.
m
0
l
July 15, 2013 8:57:06 AM

The Q6660 Inside said:
Can Boluk said:
All the info on CPU-Z and GPU-Z


It says it is running @2.0 X16@X8, that seems odd. I think it had something to do with early drivers, try updating your video card drivers at nVdia's website.

using the latest 340.xx :?
m
0
l
July 15, 2013 8:59:00 AM

Perhaps can you take a picture of your PSU?
m
0
l
July 15, 2013 9:01:11 AM

The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )

m
0
l
July 15, 2013 9:03:34 AM

Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.
m
0
l
July 15, 2013 9:04:49 AM

The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.

People in another forums say that x8 can be because of USB 3.0 and SATA 3.0 using PCI-E, should i try it?=

m
0
l
July 15, 2013 9:12:38 AM

Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.

People in another forums say that x8 can be because of USB 3.0 and SATA 3.0 using PCI-E, should i try it?=



Try moving the GTX 680's slot to the red one below it (Seriously, dust it off with case while you are at it :lol: ). Then download the new drivers and use the SweetFX injector instead of MSAA.
SweetFX tutorial http://www.youtube.com/watch?feature=player_detailpage&...
m
0
l
July 15, 2013 9:16:27 AM

The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.

People in another forums say that x8 can be because of USB 3.0 and SATA 3.0 using PCI-E, should i try it?=



Try moving the GTX 680's slot to the red one below it (Seriously, dust it off with case while you are at it :lol: ). Then download the new drivers and use the SweetFX injector instead of MSAA.
SweetFX tutorial http://www.youtube.com/watch?feature=player_detailpage&...


not sure if there is enough place + fan wont have space if it has space.
m
0
l
July 15, 2013 9:21:53 AM

Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.

People in another forums say that x8 can be because of USB 3.0 and SATA 3.0 using PCI-E, should i try it?=



Try moving the GTX 680's slot to the red one below it (Seriously, dust it off with case while you are at it :lol: ). Then download the new drivers and use the SweetFX injector instead of MSAA.
SweetFX tutorial http://www.youtube.com/watch?feature=player_detailpage&...


not sure if there is enough place + fan wont have space if it has space.


Try it and see if it fits, do you have any other PCI-E cards installed by the way? You seem to have the latest drivers.
https://forums.geforce.com/default/topic/521828/geforce... Try this.
m
0
l
July 15, 2013 9:39:45 AM

The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.

People in another forums say that x8 can be because of USB 3.0 and SATA 3.0 using PCI-E, should i try it?=



Try moving the GTX 680's slot to the red one below it (Seriously, dust it off with case while you are at it :lol: ). Then download the new drivers and use the SweetFX injector instead of MSAA.
SweetFX tutorial http://www.youtube.com/watch?feature=player_detailpage&...


not sure if there is enough place + fan wont have space if it has space.


Try it and see if it fits, do you have any other PCI-E cards installed by the way? You seem to have the latest drivers.
https://forums.geforce.com/default/topic/521828/geforce... Try this.


No , i dont, actually i just overclocked to
4.4 GHZ with 1.375 core volage , i dunno it seems so slow to open, should i reset maybe ?
m
0
l
July 15, 2013 9:53:30 AM

Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Can Boluk said:
The Q6660 Inside said:
Perhaps can you take a picture of your PSU?

(thanks for still trying to help me btw :)  )


It should do fine, but upgrade to the one linked when you have enough money. Anyways, download the driver and SweetFX injector shown and see if you have any improvements.

People in another forums say that x8 can be because of USB 3.0 and SATA 3.0 using PCI-E, should i try it?=



Try moving the GTX 680's slot to the red one below it (Seriously, dust it off with case while you are at it :lol: ). Then download the new drivers and use the SweetFX injector instead of MSAA.
SweetFX tutorial http://www.youtube.com/watch?feature=player_detailpage&...


not sure if there is enough place + fan wont have space if it has space.


Try it and see if it fits, do you have any other PCI-E cards installed by the way? You seem to have the latest drivers.
https://forums.geforce.com/default/topic/521828/geforce... Try this.


No , i dont, actually i just overclocked to
4.4 GHZ with 1.375 core volage , i dunno it seems so slow to open, should i reset maybe ?


Try overclocking to 4.0GHz and lower the voltage to around 1.23. Also, after doing that, run the PCI-E Patch and clean the system :lol: . Remember to disable C1E and SpeedStep.
m
0
l
July 15, 2013 10:51:35 AM

The Q6660 Inside said:
Also, remember to enable XMP.

What is XMP?
I disable C1E and speedstep, with the same voltage im @ 4.6 GHZ now its all okay, but the patch didnt work for me it says something like

SYSTEM\ControlSet001\Control\CLASS\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000
and doesnt to anything :|
m
0
l
July 15, 2013 11:05:55 AM

Can Boluk said:
The Q6660 Inside said:
Also, remember to enable XMP.

What is XMP?
I disable C1E and speedstep, with the same voltage im @ 4.6 GHZ now its all okay, but the patch didnt work for me it says something like

SYSTEM\ControlSet001\Control\CLASS\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000
and doesnt to anything :|

Be sure to run Prime 95 for at least 30 minutes and validate it with CPU-Z validator. Try to update your Motherboard's BIOS and clean the system out :3
http://valid.canardpc.com/
On the Extreme Tweaker, there should be something called "XMP", be sure to enable it.
PS: Click on the "Question Mark" next to where it says PCI-E 2.0 x 16@8 to show the actual PCI-E version\speed it is running at.
m
0
l
July 15, 2013 11:33:13 AM

After the system is cleaned, give Crysis 3 a try and maybe it is fixed, make sure the Crysis 3\Far Cry 3 settings are saved to 2X or 4X MSAA.
m
0
l
!