Solved

7850 not recognised by device manager

Hi all,

Have just upgraded my rig with new MoBo, CPU and graphics card.

When I first set all the gear up, connecting the DVI cable to the new graphics card worked. I then installed some MoBo drivers and the card no longer worked - I had to connect a HDMI cable to the integrated graphics. Since installing all the MoBo drivers and the graphics card drivers, I am unable to get the GPU recognised by my computer - it is not listed under device manager. The fans on the card do spin, and clearly it does work (though I haven't been able to test it in another computer). Putting my old 8800GTS into the same slot in the MoBo works, so the PCIe slot can't be at fault, either. I'm really stumped with this, so any advice would be great.

MoBo: gigabyte GA-Z68AP-D3
GPU: Sapphire radon HD 7850

Bios and drivers etc. are up to date
1 answer Last reply Best Answer
More about 7850 recognised device manager
  1. Best answer
    Sounds like a driver conflict issue. Use this tool : http://www.techspot.com/downloads/4266-driver-sweeper.html

    Than use the vendor driver for GPU, see how it works.
Ask a new question

Read More

Device Manager Graphics Cards Drivers Graphics