Sign in with
Sign up | Sign in
Your question
Solved

How come my HDMI cable doesn't work with AMD Radeon HD but ut works with Intel HD Graphic?

Last response: in Graphics & Displays
Share
July 17, 2013 5:52:52 AM

My graphic Card is Powercolor HD 7770 Ghz Edition and I have a HDMI Cable.
When I use my cable to connect my HD 4600 to the TV, it works but when I use it to connect my HD 7770 to my TV, no signal.
As first I though my HDMI port is broken (DVI port works well) so it bring it to the shop for warranty. However, they test the card and there is no problem with it. To day I came to get by card back. I also brought my HDMI cable with me. They used their own HDMI cable and it worked perfectly but when they used my HDMI cable, no signal. They told me that my HDMI cable got problem. :bounce: 
However, I came home and tested my cable again. My cable works perfectly with the Intel HD graphic and I don't get any signal from the HD 7770. :??: 
Intel is really that superiour :??: 
So my only though is that may be HDMI comes with different revision. Can
somebody tell me what's going on.
Thanks
a c 218 U Graphics card
July 17, 2013 6:13:24 AM

Did you try another HDMI cable at home? There could indeed be a problem with your cable. For example, the orientation of the on-board vs. HD7770 HDMI ports (assuming one is vertical and the other horizontal) could allow a bad connection internal to the cable to work part of the time as wires/connectors are pressed together, but may not work in any other position.
m
0
l
July 17, 2013 6:41:18 AM

COLGeek said:
Did you try another HDMI cable at home? There could indeed be a problem with your cable. For example, the orientation of the on-board vs. HD7770 HDMI ports (assuming one is vertical and the other horizontal) could allow a bad connection internal to the cable to work part of the time as wires/connectors are pressed together, but may not work in any other position.

I also thought that maybe the cable is not fully connected.
I pluged the HDMI into the HD 7770 and I tred to push it hard, rotale the HDMI cable it in every direction, rotate my PC case,... and no good result.
m
0
l
Related resources

Best solution

a c 218 U Graphics card
July 17, 2013 6:46:23 AM

OK. Did you try another cable? Also, have you verified that the AMD HDMI drivers are properly loaded?
Share
July 17, 2013 7:05:57 AM

COLGeek said:
OK. Did you try another cable? Also, have you verified that the AMD HDMI drivers are properly loaded?


I'm sure that the Catalyst Driver installed correctly and up-to-date. I play Far Cry 3, Batman Arkham City with with it. No problems with the DVI. I bough the card from ferbuary and had the same problem with my old G41-vs3 mainboard. Now I have upgraded my PC and still... The guys at the shop shows me the Graphic Card working with another HDMI cable, but not mine. I cannot understand lol
m
0
l
July 25, 2013 6:01:49 AM

COLGeek said:
OK. Did you try another cable? Also, have you verified that the AMD HDMI drivers are properly loaded?


OK
I handled the problem.
My VIdeo Card comes with HDMi 1.4 and for some reason (who knows), it's not compatible with 1.3 and below. I get a HDMI cable v1.4 and the problem is solved.
Thanks for helping me anyway
m
0
l
!