Solved

Used wrong PSU wattage for the motherboard

I'v just started building my first gaming rig and I just wanted to test the motherboard with the PSU i had which was only 450watts and I didn't have any other PSU's at this stage..
I didn't realize that the motherboard iv got needs 500watts to work and now that Iv got the right PSU for it I get no display or POST beeps.
I'm pretty sure that I have broke the motherboard but I just wanted a second opinion just in case anyone thinks otherwise, I have tried everything I can think of to fix my problem like taking everything out and putting it back in, Making sure iv put everything in the right place, I took RAM, GPU, HDD's one at a time, Still no beeps..

Computer specs:
Winpower plus 850watt PSU,
Gigabyte GA-780T-D3L Phenom Bulldozer ATX motherboard,
1GB XFX Radeon HD 7770 DD Core Edition GPU,
AMD Phenom II X4 965 Quad Core 3.4GHz CPU,
1 4gb RAM
2x 1TB HDD's
Everything is brand new, I haven't even got to the boot menu.
7 answers Last reply Best Answer
More about wrong psu wattage motherboard
  1. I don't think hooking a smaller power supply would damage the mobo. A 500watt psu does not put out 500watts look at the small print on the psu. Did the mobo work with the other power supply? Try clearing the cmos. Are you sure the new psu is good its not unheard of getting one doa.
  2. Try resetting bios by clr cmos after taking out the power cord

    If it does not solve the prob tak out the button cell from mobo and insert it after 10 mins


    If it also doesnt work then connect fan to the mobo and check if it works

    If it doesnt either your cpu or mobo is fried up

    Most probably the cpu

    Mine 965be. was fried up a week before


    Was the graphics card connect on the frst boot ???
    Is the graphic card fan running on power on???
  3. Test ur new psu by discnnctin all its cnnection

    Take the help of the link
    This will chck the psu
    http://www.yinfor.com/blog/archives/2008/03/replac_the_fan_of_power_supply.html
  4. Sn1992-1361850 said:
    Test ur new psu by discnnctin all its cnnection

    Take the help of the link
    This will chck the psu
    http://www.yinfor.com/blog/archives/2008/03/replac_the_fan_of_power_supply.html


    Yep I tried that aswell, I took out the cmos for about 5 mins and still nothing, I hope to god it isn't the CPU because it cost me £90 lol.. Everything works with the mobo like the fans and LED lights and the heat sinker..
    When I tried use my old PSU the computer would come on for about half a second then shut off.
  5. Best answer
    I m sure ur cpu is out
    U can try one thing that get the cpu to the service centre and tell them it was a DOA i hope u could get the cpu replaced

    Best of luck

    Dont forget to close the post by choosing best solution
    We would all appreciate it
  6. Sn1992-1361850 said:
    I m sure ur cpu is out
    U can try one thing that get the cpu to the service centre and tell them it was a DOA i hope u could get the cpu replaced

    Best of luck

    Dont forget to close the post by choosing best solution
    We would all appreciate it


    NO!! Only joking lol.. Okay thanks for your help anyways :)
  7. Ohkay
    Dont forget to close the post by selecting the best answer
    We all would really appreciate it
Ask a new question

Read More

Hardware Gaming Motherboards Displays