Motherboard Gigabyte GA-970A-UD3 Does Not Read Hard Drive

I just bought a new motherboard along with new CPU and used a 2TB Samsun HD203WI hard drive along with the build. But the motherboard does not read the harddrive... and I can't seem to get the motherboard to display the hard drive in BIOS.

I swap out new sata cables, made sure all cables are connected securely, untangled all wires and binded it for better airflow...still not working.

I even got a live boot of Ubuntu off my thumbdrive but the hard drive still doesn't show up in Ubuntu.

Ran GParted. No luck.

Right now I'm stuck. If anyone can give me some directions here, that will be great! A lot of trial and erros here...
3 answers Last reply Best Answer
More about motherboard gigabyte 970a ud3 read hard drive
  1. Best answer
    Well to me it sounds like a bad hard drive. But what port do you have the drive plugged into? Since this is your primary drive make sure you have it plugged into port 0 on your motherboard and make sure the controller is actually activated in the BIOS.
  2. I plug in different hard drives that works on one computer but doesn't on the new build. I have the controller enabled because when I plug in my dvd drive to port 0, it reads that the drive is connected and displays in the bios and works. But when I connect that same sata cable from port 0 into my hard drive, it doesn't show up in BIOS not does it work.
  3. did you fill spinning hdd with working power connector?
Ask a new question

Read More

Gigabyte Motherboards Hard Drives