PSU rails voltage weird

Aida64 reads:
+3.3V 3.392V
+5V 5.699V
+12V 12.890V
+5V standby 5.309
Are these ok?

PSU is Fortron Saga II 400W
CPU: AMD Phenom II X4 965 undervolted @ 3.2ghz
CPU Cooler: Scythe Samurai ZZ
GPU: Gainward GT 440
Motherboard: ASRock - 960GM-GS3 FX
Case: Delux MT375 ( http://imageshack.us/a/img4/3605/ao0a.jpg )


Sometimes, it smells like something is burning, for a few seconds, and then the smell disappears...
I tried finding the source of the smell, but I didn't find it.

Does the PSU has enough space for cooling?
http://imageshack.us/a/img43/5194/smv4.jpg
I also have a 80mm fan blowing in the back, and 80mm fan sucking air, blowing on GPU...

Should I buy a new PSU?
3 answers Last reply
More about psu rails voltage weird
  1. I wOuld take the power supply back for a refund if you can the 12v and 5v lines are high. Don't want to see your rig catch on fire.
  2. killerkiller11 said:
    Aida64 reads:
    +3.3V 3.392V
    +5V 5.699V
    +12V 12.890V
    +5V standby 5.309
    Are these ok?

    PSU is Fortron Saga II 400W
    CPU: AMD Phenom II X4 965 undervolted @ 3.2ghz
    CPU Cooler: Scythe Samurai ZZ
    GPU: Gainward GT 440
    Motherboard: ASRock - 960GM-GS3 FX
    Case: Delux MT375 ( http://imageshack.us/a/img4/3605/ao0a.jpg )


    Sometimes, it smells like something is burning, for a few seconds, and then the smell disappears...
    I tried finding the source of the smell, but I didn't find it.

    Does the PSU has enough space for cooling?
    http://imageshack.us/a/img43/5194/smv4.jpg
    I also have a 80mm fan blowing in the back, and 80mm fan sucking air, blowing on GPU...

    Should I buy a new PSU?


    Hi - a couple (+5v &+12v) are a little higher than optimum, but don't
    appear to problematical.

    Of bigger concern is the smell you get when powering up. If you can
    dertime it's the PSU (likely), then yes I'd opt for a new PSU.

    It looks like cooling is not an issue, are you able to get accurate temps?
  3. toyftw said:
    killerkiller11 said:
    Aida64 reads:
    +3.3V 3.392V
    +5V 5.699V
    +12V 12.890V
    +5V standby 5.309
    Are these ok?

    PSU is Fortron Saga II 400W
    CPU: AMD Phenom II X4 965 undervolted @ 3.2ghz
    CPU Cooler: Scythe Samurai ZZ
    GPU: Gainward GT 440
    Motherboard: ASRock - 960GM-GS3 FX
    Case: Delux MT375 ( http://imageshack.us/a/img4/3605/ao0a.jpg )


    Sometimes, it smells like something is burning, for a few seconds, and then the smell disappears...
    I tried finding the source of the smell, but I didn't find it.

    Does the PSU has enough space for cooling?
    http://imageshack.us/a/img43/5194/smv4.jpg
    I also have a 80mm fan blowing in the back, and 80mm fan sucking air, blowing on GPU...

    Should I buy a new PSU?


    Hi - a couple (+5v &+12v) are a little higher than optimum, but don't
    appear to problematical.

    Of bigger concern is the smell you get when powering up. If you can
    dertime it's the PSU (likely), then yes I'd opt for a new PSU.

    It looks like cooling is not an issue, are you able to get accurate temps?



    A few months ago, left my PC on. When I come back, my mom told me that she smelled something it's burning, and told me to check the pc...
    I blowed the dust twice today, and also checked everything (ram, gpu, cables, i was looking for spots on mb, smelled every component), but nothing...
    I tried using cpu, gpu and hard drive at 100%, no smell...
    It happened when I was surfing on the internet, it happened when I was playing some games...
    Yesturday I discovered about mining, and left almost all day my pc on, on mining (that means the GPU was at 100% usage)
    I even tried closing my room, leaving it for a time, then come back and smell everything, still nothing...

    Any tips?
Ask a new question

Read More

Power Supplies Temperature Burner Cooling Fan Components Cases