Sign in with
Sign up | Sign in
Your question
Solved

HD6850 can't run FC3 on low?!

Last response: in Graphics & Displays
Share
July 21, 2013 2:49:35 AM

For some reason, my AMD radeon HD6850 is not even able to run FC3 on low. (And by low I mean everything is off and all the settings are low) Its running @ 100% usage in game while my CPU and RAM are both well under 100%. This happens immediately when I start my game up BTW, so probably not an overheating problem.

For comparison, in BL2 medium settings, I am able to run it at 15-30FPS. Most of the time in the high twenties. Although in BL2 the GPU usage is also at 100%, it is definitely more playable than FC3.

Both cases I expect my GPU to run much better, but the FC3 case is definitely more extreme...

I use a program called ATi Tray Tools. I was recommended this program because around 1 year ago my GPU kept crashing in-game. Once I've downloaded this program I no longer crash. Perhaps this might be a cause for the performance issue?

Any help? Thanks,

**System Specs**

HD6850
Core i3 2100
4GB corsair RAM
22'' Asus 1980x1080 monitor
Gigabyte motherboard

More about : hd6850 run fc3 low

a b 4 Gaming
a b à CPUs
a b U Graphics card
July 21, 2013 2:55:28 AM

have you installed the latest drivers?
m
0
l
July 21, 2013 2:59:44 AM

Should I be updating from the XFX website or updating my ATi Tray Tools?
m
0
l
Related resources
a b 4 Gaming
a b à CPUs
a b U Graphics card
July 21, 2013 3:02:53 AM

update from the AMD website
m
0
l
July 21, 2013 3:15:52 AM

I updated it from the AMD website and have the Catalyst Control Center. However, at the end of the installation it informed me that it failed to download the display driver.
AMD Display Driver
Final Status: Fail
Version of Item: 12.104.0.0000
Size: 90 Mbytes
m
0
l
a b 4 Gaming
a b à CPUs
a b U Graphics card
July 21, 2013 3:46:59 AM

are you willing a to do a clean reinstall of windows? it is a 60% chance that the problem is solved if you do that. after you reinstalled windows install the latest drivers from amd website.
m
0
l
July 21, 2013 4:04:23 AM

Same issue. Display driver failed to download. Perhaps the ATi tray tools has something to do with it?
m
0
l
a b 4 Gaming
a b à CPUs
a b U Graphics card
July 21, 2013 4:18:07 AM

make a clean uninstall of the drivers and install the drivers from amd website
m
0
l
July 21, 2013 7:50:38 AM

How do I completely uninstall all my display drivers?
m
0
l
a b 4 Gaming
a b à CPUs
a b U Graphics card
July 21, 2013 3:35:48 PM

download a registry cleaner like "Ccleaner" and do some registry cleaning and try to look in the registry and delete any traces of the previous drivers.
m
0
l

Best solution

a b 4 Gaming
a b à CPUs
a b À AMD
a b } Memory
a b U Graphics card
July 22, 2013 10:40:00 AM

download driver sweeper and uninstall ur previous drivers and install the latest and enjoy. It works like a charm:) 
Share
a b 4 Gaming
a b à CPUs
a b U Graphics card
July 22, 2013 11:39:54 AM

When I played Borderlands 2, I was using a slower card than your's and got much higher framerates than that. So definitely something wrong there. Hopefully drivers will sort it out for you.
m
0
l
July 30, 2013 9:52:56 AM

I've used ccleaner and driver sweeper before, although for a different problem (still GPU related though). Ill try again and hope that it solves my current problem while my previous problem doesn't come up again. As I mentioned before, using ATi tray tools somewhat solved my crashing problems. Does any of you know whether ATi tray tools might affect the original amd drivers in any way?

UPDATE: successfully downloaded and installed the new amd drivers. However I cannot actually open the CCC. I receive an error that says "could not load file or assembly 'CLI.Implementation' or one of its dependencies. The system cannot find the file specified.
m
0
l
a b 4 Gaming
a b à CPUs
a b À AMD
a b } Memory
a b U Graphics card
August 1, 2013 12:40:21 AM

uninstall it and install the driver version named"13.5 beta 2"
m
0
l
a b 4 Gaming
a b à CPUs
a b À AMD
a b } Memory
a b U Graphics card
August 1, 2013 12:41:04 AM

and uninstall the ATI tray tools
m
0
l
!