Solved

My PC wont fully boot after a new cpu

So today I revived my new cpu and I wanted to install it right away so I did. I know that the cpu is DEFINATLY compatible to tge mother board but I put in my old cpu and vwola! It still didn't work I don't know what happend something is wrong I can here the hardrive starting and see the motherboard LEDs coming on and all the fans come on even the cd drive opens but closes automatically but the computers power light doesn't turn on. I'm not the best about hardware but I know that everything is installed properly.
So can anyone please help, thanks. :)
3 answers Last reply Best Answer
More about wont fully boot cpu
  1. Best answer
    HiDDEN-KiLLZ said:
    So today I revived my new cpu and I wanted to install it right away so I did. I know that the cpu is DEFINATLY compatible to tge mother board but I put in my old cpu and vwola! It still didn't work I don't know what happend something is wrong I can here the hardrive starting and see the motherboard LEDs coming on and all the fans come on even the cd drive opens but closes automatically but the computers power light doesn't turn on. I'm not the best about hardware but I know that everything is installed properly.
    So can anyone please help, thanks. :)


    if you have an old cpu to use, try updating the bios before installing the new cpu
  2. You'll have to be more specific, what processor? what motherboard? If it's AMD, you often have to update the BIOS if you're switching from Phenome II to FX for example.
  3. oczdude8 said:
    HiDDEN-KiLLZ said:
    So today I revived my new cpu and I wanted to install it right away so I did. I know that the cpu is DEFINATLY compatible to tge mother board but I put in my old cpu and vwola! It still didn't work I don't know what happend something is wrong I can here the hardrive starting and see the motherboard LEDs coming on and all the fans come on even the cd drive opens but closes automatically but the computers power light doesn't turn on. I'm not the best about hardware but I know that everything is installed properly.
    So can anyone please help, thanks. :)


    if you have an old cpu to use, try updating the bios before installing the new cpu


    My old cpu won't even boot it its something else
Ask a new question

Read More

Boot CPUs Motherboards