Sign in with
Sign up | Sign in
Your question
Solved

SSD issues with Marvell sata controller

Last response: in Storage
Share
July 24, 2013 6:37:03 AM

I recently built a new system with an Asus PX79 pro motherboard, a HDD and a Crucial M4 SSD. I plugged the HDD and the SSD on the Intel 6G and Marvell 6G port of my motherboard, respectively.

After installing Windows (7 x64) and all drivers, I began to have file corruption issues with the SSD (the HDD ran fine). After many tests, I found that the "Marvell 91xx 6G sata controller" driver was causing this (I ran the same tests with the driver disabled, and everything was fine). Also, I didn't found any more recent version of the driver on Asus website.

This led me to these questions :
- Could this be a bug with the driver, or me doing something wrong ?
- What is the real use of the driver anyway, if the SSD works without it ? (apart from not having the Windows peripheral manager complaining :) )
- Should I just give up, leave the Marvell sata port alone, and switch my SSD to the Intel port ?


Thanks for your advice :) 

More about : ssd issues marvell sata controller

Best solution

a c 544 G Storage
a b V Motherboard
July 24, 2013 6:59:07 AM

tenseiken said:
Should I just give up, leave the Marvell sata port alone, and switch my SSD to the Intel port ?


Correct. Even if you find a solution to your problem and resolve your file corruption problems your Read/Write performance will still be slower on the Marvell 6Gb/s controller than on Intel 6Gb/s controller.

The Marvell 6Gb/s controller has a bandwidth of PCIe x1 at 5Gb/s (500MB/s). The controller was originally designed for HDDs and 1st generation SSDs. You won't get advertised Read/Write speeds from current generation SSDs.
Share
July 24, 2013 7:00:33 AM

Leave the Marvell Sata port alone. I'm pretty sure there are known issues with the Marvel Sata controllers. Put your SSD on the Intel SATA.
m
0
l
Related resources
July 24, 2013 8:06:28 AM

Dereck47 : Yes, you're right, if it isn't even as fast as standard controllers, I wonder why I'm still wasting my time with it.

tobensg : I heavily googled this issue but strangely I didn't found anyone having the same problem. I just wish Marvell never put their crappy controller on my motherboard, I lost almost 2 months to track the issue and realize it wasn't the SSD that was faulty :( 

Anyway, issue closed,
Thanks to both of you for your answers :) 
m
0
l
October 31, 2013 2:38:36 PM

Hi tenseiken,
I have a big issue with my 2 SSD OCZ Vector 256GB on Intel SATA6G port on asus P9X79WS.
Raid1 is ok in IRSTe 3.6. But after some writing, my raid1 failed and nothing to do except to restart my computer.
Then I find again my raid and I could check errors in IRSTe but I have some corrupted files.

Do you think I have to plug them Intel sata3G instead of?

Thanks
Steph

m
0
l
October 31, 2013 3:08:31 PM

I 've just read that it's better to install IRST 12.8 instead of Enterprise 3.7 for X79. Even if there are no trim with Raid1.
m
0
l
November 2, 2013 8:05:11 AM

Hi gregstephen,

I personnaly did not try to put SSDs in raid1 on my PC, so I'm afraid I won't be of any help :( 
The only thing I'm sure about : if you have to choose between an Intel SATA port and a Marvell SATA port, choose the Intel port !
Since you mentionned having an Intel port, I think switching to SATA3G won't solve your problem, so you should definitely try other drivers. Did you do some stability/read/write tests with the IRST 12.8 ?
m
0
l
November 2, 2013 10:34:45 AM

Thanks...
No Asus put only RST 11.7 whql not 12.8, maybe I Shouldn't put them until they are whql.

I'll install driver monday, we'll see...

Bye
Steph

Update:
Nothing works!
I tried 3.7 and 3.8 IRSTe, all SSD are on Intel sata controller => ever same issue with corrupted files.
11.7 or 12.8 are not compatible with Intel C600+/220+ chipset
For the moment, I disabled Raid and put on AHCi.





I'll try to mount Raid on Marvell 9128 Controller instead of.
m
0
l
!