Amd Athlon 2 x4 620 heat problem

So i recently got this old PC back.. What i saw was a weird thing, the CPU temperature was above the normal temps.
Here are some Pictures http://tinypic.com/r/2mynp21/5
and http://tinypic.com/r/140dzfa/5
I ran Prime-95 to test the load temps. They were exceeding the max temperatures of the CPU. I got like 76 C!!! and i immediately shut down prime. Those temperatures were like 5 C above the max(71C).
Also i noticed that the CPU fan isn't quite right, normal idle is ~3300 RPM and sometimes after a long lad time it climbs up to ~5000 RPM.
I changed the thermal paste but still no temperature drop.

When i start the PC i go in to the bios to check the temperatures, they are like 42 C. I read some topics on the internet and i see like that is the load Temperature that some people get, but mine is on idle!
Can the CPU sensor be damaged cause the PC didnt shut down when i reached that high temperature which i stated above.

Other System Specs
MB: MSI 785GM-E65
GPU:Radeon HD4850
Ram:4GB 1333mhz dual channel
PSU:720W

If you could help me fix my problem that would be great. Thanks :)
3 answers Last reply
More about amd athlon 620 heat problem
  1. didn't check links but................ did you try removing the heatsink and cleaning the old thermal paste off the processor and heatsink and reapplying new?
  2. swifty_morgan said:
    didn't check links but................ did you try removing the heatsink and cleaning the old thermal paste off the processor and heatsink and reapplying new?


    Yes i did that but still no drop in temps. Could the sensor be damaged or some false reading on tenps?
  3. try core temp.
Ask a new question

Read More

AMD Temperature CPUs Heat Hardware Problem