Sign in with
Sign up | Sign in
Your question

Windows failing to boot after recent hardware problem

Last response: in Systems
Share
July 25, 2013 5:15:20 AM

Hi folks,

Fairly recently, folks here helped me resolve this issue.

Since then, the computer has been working fine (it has been about two weeks). However, today, as I went to fire the machine up, it failed to boot into Windows. I don't have the specific error message right now, but it was something along the lines of a boot device couldn't be found. (I will update this tonight with more detail.)

It gave me an option of trying to Launch Windows anyway, which I tried, but it blue-screened and rebooted itself each time I tried. It was also suggested that I put my Windows disk in and run repair. I did this (Win 7 Home Premium). The repair process failed to fix anything. It did suggest at one point that if I had added any hardware recently, I should remove it and try again.

Per the thread I linked above, I did install a new CPU fan as part of resolving that issue. However, it seems peculiar that that would be the issue, since it has been working great with that fan for the past two weeks or so. (Also, I had to take out the entire motherboard to install this fan, so I'd really rather not uninstall it if I can avoid it!)

So, at this point, I cannot boot into Windows at all, which means I am dead in the water. Any suggestions for how to troubleshoot?

Thanks very much!

Steve
July 25, 2013 10:26:13 AM

Boot device not found points to a possible HDD failure.
It could also mean that the power or data connecter for the HDD is loose.
Or it could mean that your boot order in BIOS is messed up.

Double check all of your connections for your HDD both on the drive itself and on the MB/PSU. Ensure that in BIOS your HDD with Windows is set to first boot.
July 25, 2013 12:17:33 PM

Thanks very much for your reply Dhamilton!

Quick reply...

It's definitely not the boot order. I had to go in there to boot from the Windows DVD, and it was set correctly. (And like I said, the computer had been working fine the day before.)

So, I will check the power connectors tonight and report back. Since I had to disconnect and reconnect everything when I took out the motherboard to put the fan in, that seems like the most likely situation. (Hopefully. Would rather that than having an HDD failure. Luckily, I backed up fairly recently.)
Related resources
July 25, 2013 8:00:10 PM

Alright, so, progress.

When I boot, it gives me an option to launch repair, or start Windows normally. As mentioned earlier, repair doesn't seem to do anything. When I try to start Windows normally, it blue screens like this:



Additionally, I was able to get the machine to boot into Safe Mode, which tells me at least that my hard drive is intact.

Any suggestions for what to try next?
July 26, 2013 9:48:49 AM

Check your USB drivers and Device Manager when you boot into safe mode.
USBPORT.SYS is where the error occured

You need to DL updated chipset drivers from your MB manufacturer website or your BIOS needs to be updated.
Check if you have the latest here : http://www.asus.com/Motherboards/P7P55D/#support_Downlo...
July 26, 2013 10:17:39 AM

Alright, I think your advice may be too late. I am at home today, and was hoping to do this, but now I can't get it to boot into Safe Mode any more. :(  When I ran Windows Repair the other day, I could choose my OS and run repair. But today my OS doesn't appear at all. :( 

Is it Windows reinstall time, I wonder??
July 26, 2013 10:47:30 AM

Well, my BIOS is version 1408, and there have been five updates since then, so presumably I should update that first?
July 26, 2013 10:50:07 AM

If you are not worried about data loss you could try to reinstall the OS first.
If it fails next step would be BIOS update.
After that I would start suspecting your HDD or MB as being faulty
July 26, 2013 10:59:02 AM

I was hoping to avoid the reinstall just for the pain in the butt factor of trying to dig up all of my software keys, etc. :) 

Do you know, is there some magic secret to that stuff?
July 26, 2013 11:20:21 AM

Boot from your Windows install media, get yourself to a command prompt
at the prompt run a chkdsk /f/r
this will scan the drive for errors and problems and attempt to fix them. It will probably take awhile but can give an idea if the physical hdd is the problem ( instead of trying the install)

you could also, if you have enough space on the hdd, install windows on the same partition as before. this would rename your previous install so it does not function. Your data would be preserved
The BIOS update probably should be done, but I am always concerned about doing that because if their is a problem with the board itself the BIOS update might cause it to brick.
As a result you should do the chkdsk to confirm that the disk itself is OK.
July 26, 2013 11:35:29 AM

So, when I try to run a check disk on c:, it says "Cannot run because the volume is in use by another process. Chkdsk may run if this volume is dismounted first. ALL OPENED HANDLES TO THIS VOLUME WOULD THEN BE INVALID. Would you like to force a dismount on this volume?"

Thoughts?


Never mind, figured it out.
July 26, 2013 11:41:27 AM

Yes that is fine to force the dismount. It is basically saying that a process is using the disk and chkdsk needs exclusive access to the drive to work correctly.
Just make sure you are booting from the installation media and not a recovery disk.
If it happens again after allowing the dismount that points to a disk failure.
July 26, 2013 1:06:27 PM

OK, so here's where we stand.

Managed to run chkdsk. No changes in the end results though.

I happened to have a Corsair CMFSSD 64GB SSD drive handy. :)  (It used to be my boot drive, but I had a problem, and returned it. They sent me a new one and I never got around to reinstalling it.)

So, my plan of attack is to install a new copy of Windows on that drive, then recover what I need from the old drive.

I have run into a problem with that, but should I post that in a separate thread, as it's not technically part of the same problem?
July 26, 2013 1:26:12 PM

Up to you on new thread or not. Keep in mind that your firmware is still not updated.
For a clean SSD install unplug the other drive and use AHCI mode set in BIOS
Just as a note since we didn't talk about it. Unplug any USB items that are not absolutely necessary (kb/mouse) from the system.
July 26, 2013 1:37:10 PM

OK, I unplugged the existing two hard drives and plugged the SSD in, and I got past my problem. Windows is installing now. Whee! (There is something tremendously satisfying about a fresh install... :)  )

Presumably once I have that up and running, I would reconnect the other hard drives so that I can get at their data?
July 26, 2013 1:40:25 PM

Yes indeed.
Just ensure that when you reinstall the other drives you have the ssd as first boot ( the others lowest or never)
I hope the fresh install succeeds for you.
July 26, 2013 2:19:11 PM

Fresh install worked so far! Made it through one round of Windows Updates, then a reboot. Now it's working on another batch of updates, but it has been hung on "Preparing to install" for a very long time (30+ min). It was a really large batch of updates, though, so I'm not too stressed yet.

Have to go out for a few hours, and will just let it run, and see what things look like when I return!

Thanks again... Once I get a little farther in this process I will close this thread...

Steve
July 27, 2013 10:41:43 AM

So, disappointing news. :( 

The Windows reinstall onto my SSD seemed to be working great. I was in the process of getting my software reinstalled and a billion Windows updates applied. Unfortunately, right after installing MS Office 2007, I had to reboot, and now I am back to an "unbootable" state somehow.

I'm seeing a lot of variability. Last time I booted I got what I was getting before (you can try repair or launch windows normally). I tried to launch Windows and it rebooted itself and failed again. I turned off the PC for 30 minutes and tried again, and then I got "A disk read error occurred, press Ctrl+Alt+Del to restart." Grrrr.

I had plugged both of the HDDs back in, so I had the 1 SDD and 2 HDD, and I was able to see them all when Windows was running successfully. So, I thought perhaps one of those HDD was causing the problem, although I wasn't sure if that was even possible.

So I unplugged the HDDs so that only the SDD was in there, after which I got "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key."

So, I went back into the BIOS, and where it used to show my Corsair SDD drive as the boot device, now it just says "Hard Drive." (I can't recall exactly what it said before, but it was some specific combination of characters that made it clear it was the Corsair SSD, not just the generic "Hard Drive".)

So, I am getting the feeling here that there is something wrong with the motherboard. :(  Suggestions? Should I just try plugging the Sata cable for the SDD into a different port on the motherboard? Or is that not likely to help?

Thanks again...

Steve
July 27, 2013 11:06:06 AM

Well you have ruled out the drives and the OS install
You can try switching the cables if you want to.
Think its time to do that firmware upgrade for your BIOS
July 27, 2013 11:55:12 AM

Did the firmware upgrade successfully.

Tried the Sata cable switch. No love. It is not recognizing my SDD at all any more. :( 

Stupid question: does it matter which order you plug things into the mobo? For example, my board has 6 Sata spots, numbered 1-6. Do I have to have a "1"? Similarly, for the power, the cable has a string of power plugs. Do I have to plug them in in order or anything like that?
July 27, 2013 12:03:42 PM

Hmm I might have part of my own answer. I moved the SDD from Sata 2 back to Sata 1, and now it's at least appearing in the BIOS.

Aaaaaand, I made it back into Windows again. Hmmm...

So now I am in Windows. My confidence is pretty low in the stability of this thing.

So then I plugged the two HDDs back in and rebooted, and poof I am back at "failure to start Windows"...
July 27, 2013 12:10:05 PM

Tried again with just one of the HDDs plugged in, same result. Swapped HDDs, same result.

Pulled out both HDDs, and now my SDD can't be seen in the BIOS again. WTF... I am having trouble nailing this thing down!
July 27, 2013 12:15:28 PM

So, I unplugged the Sata cable for the SDD and plugged it back into the exact same spot, and now the SDD is back and visible in the BIOS, and I can boot into Windows.

WTF.
!