Sign in with
Sign up | Sign in
Your question

Motherboard LED blinks but no power

Last response: in Motherboards
Share
July 25, 2013 8:16:42 PM

Devastating! Please help!!

This is my first build with no prior building experience. With the help of all of you on this forum and on tonymac's I was able to build what I thought was a successful system with what seemed like high quality components loading both Mountain Lion and Windows 7. I put together the system 2 days ago installing each OS as directed and all was going smoothly. Upon returning to my computer, which had been powered off for a couple of hours, I had noticed that the usually bright LED on the motherboard visible through the case wasn't on. I thought that maybe I had turned off the PSU switch, however that was not the case. I switched it off and back on and all I got was a blink from the LED on the motherboard. No fans powered on, nothing. I disconnected all of the peripheral and still no power to the motherboard, just a blink. I've spent the last 6 hours reading message boards suggesting it could be the power supply or motherboard, but how could this be possible with the types of parts I used only after 2 days? I was quite careful, even using an anti-static wrist strap and haven't in the slightest bit stressed the computer other than browsing the web. Please help this is extremely disappointing...

MOBO: Gigabyte GA-Z77X-UD5H
CPU: Intel 3770k
PSU: CoolerMaster 700w Silent Pro
MEMORY: 16GB Corsair Vengance
VIDEO CARD: EVGA GT 640
SSD: 120 GB Kingston
SSD: 120 GB SanDisk
Wireless Adapter: TP-Link WDN-4800

Thanks in advance.

Update:I attempted the paper clip test and the psu seems to be fine, all the fans except the cpu fan powered on...so is it safe to say the motherboard has somehow failed after 2 days of use?
July 26, 2013 7:05:07 AM

Tradesman1 said:
Might want bench it and troubleshoot, have a guide I wrote that might help here:

http://www.gskill.us/forum/showthread.php?t=11279


I have tried most of those through the night, but no luck. Still the same blink from the LED of the motherboard...

And I thought this hobby had a future in it for me...:??: 
Related resources
a c 1283 V Motherboard
July 26, 2013 3:48:28 PM

Do you have a different PSU you can try, or can you borrow one?
July 29, 2013 12:36:17 PM

Tradesman1 said:
Do you have a different PSU you can try, or can you borrow one?


I tried a different, brand new PSU, and this time the motherboard LED didn't even blink.
!