Solved

SSD suddenly won't boot, doesn't show in available drives

Hello,

Suddenly my Intel SSD 320 series won't boot. As far as I know, no new programs were installed or any significant changes to cause the problem. The computer still recognizes it; I can select it in the boot menu. However it was going into some kind of nvidia boot agent and then showed client mac address or something like that where it would sit for awhile before tell me no boot record (i think), now though it says disk boot failure, insert system disk.

I have another bootable drive which I'm on now, and the SSD doesn't show up in My Computer, however it does show in the device manager. I've tried updating the firmware (already up-to-date); I downloaded the intel ssd toolbox but my 120GB drive shows up as only a 8mb drive and running the diagnostic utility prompts a message saying "the selected intel ssd has no partition". I've also tried different sata ports, along with disconnecting the other drives. I don't know what else to do. Please help
3 answers Last reply Best Answer
More about ssd suddenly boot show drives
  1. There should still be warranty on it.
  2. Implying that it's all lost forever?
  3. Best answer
    Sounds like you should RMA the SSD. Pretty much the same thing happened to me twice on two different SSDs. I was reading an article not so long ago that said SSD owners were surveyed and it was found out that SSDs are prone to dying at an early age more so than HDDS.
Ask a new question

Read More

SSD Storage Intel Boot