Sign in with
Sign up | Sign in
Your question

New Hard disk DOA or Controller issues??? [ST2000DM001 on ASUS P6X58D-E]

Tags:
  • sata-3
  • Storage
  • p6x58d-e
  • Seagate
  • ST2000DM001
  • ST31000524AS
  • Asus
  • SATAIII
  • SATA III
Last response: in Storage
Share
July 28, 2013 8:38:58 AM

BG info: skip to [Problem] if you wish

I have been running a system with the below config for the past 2+years.

Intel Core i7 960
ASUS P6X58D-E Mobo
Seagate ST31000524AS [1TB] - (Running Windows 7)

[Not relevant: GSkill 6GB DDR3; Nvidia GTX 460 OC 1 GB; Corsair vx550 PSU;]

I have had no issues with the current ST31000524AS hard disk since the beginning except for some noise every now and then.

Just bought a brand new Seagate ST2000DM001 [2TB; SATA III] hard disk this week after searching long time for a vendor who could ship me one having serial no as Z1Exxxxx after I found that the non-1TB platter ones have some performance issues.

[Problem]
Have been trying to setup the new ST2000DM001 hard disk and install Windows 8 for the past two days but with no luck.
1: Updated bios to version 701.
2. I disconnected my old hard disk [to avoid and issues]
3. Connected the ST2000DM001 to a SATAIII port (which is grey color on my mobo).
4. Booted into the USB disk contain windows 8 installer.
5. The Windows installer seems to detect the new hard disk as Un-allocated 128GB only :( 
6. Also there was this warning being shown about the hard disk .
7. I tried creating a new partition hoping that might solve the issue , but was unable to create a new partition and this error message came up .

But, I noticed on the next restart that, while booting up the system detected the new Hard Disk but not correctly. Its size was shown as just 4GB!!!

So I tried different configurations and combinations to get it working.
Ex: Different SATA III port;
Change from IDE to AHCI Mode in BIOS;
Change Marvell Controller Mode to AHCI;

I searched online and on Tom's Hardware and found [jaquith's and other posts] that there were some issues with the P6X58D-E's SATA III ports. So I tried connecting the new Hard Disk to a SATA II port and then booted in.
Once I got a message as this "Sata 2 Hard Disk Error" .
The next time I got the message saying "S.M.A.R.T Capable and Status BAD" (I guess I had changed the mode to AHCI the second time , , ).

Also tried booting into old Windows 7 disk long with the new Hard Disk [new one on SATA III], but then first the installation failed so I installed new Marvell 91xx drivers and then the hard disk showed up as 128GB unallocated ;

Updated bios to 803 and tried the above but still no use.

Completely frustuated.. :(  Please help and guide.

I'm confused if the issue is with the hard Disk or the Marvell Controller.

More about : hard disk doa controller issues st2000dm001 asus p6x58d

a c 164 G Storage
a c 110 Ĉ ASUS
July 28, 2013 6:35:03 PM

That is the controller issue, somehow it sets the HD capacity to lower capacity.

All you have to do;
1)Download the Seatools ( DOS version only) from Seagate: http://www.seagate.com/support/downloads/seatools/ ( You maybe need the SeaTools for DOS guide too).
2)Burn .iso to cd, and boot up.
3)Do the Advanced Features>Set Capacity to MAX Native to restore the full capacity.
m
0
l
a c 971 G Storage
a b Ĉ ASUS
July 28, 2013 7:47:15 PM

you could try using the intel ports too. The sata3 ones on that bd are marvel and perform worse than intel sata2.
m
0
l
Related resources
a c 164 G Storage
a c 110 Ĉ ASUS
July 28, 2013 8:53:03 PM

For HDD the performance will be the same between intel and marvel port. The problem is that 1TB HDD only showed 128GB capacity.
m
0
l
July 29, 2013 8:43:35 AM

Thanks for the response cin19 and popatim.

@cin19,
I will check out ur solution with SeaTools.
Also if you see in PICS 5 you can see that its detected as 4GB in BIOS by the marvell controller.
But in Windows it shows up as 128 GB [PICS 11 & 12].

@popatim,
i have tried with the SATAII ports too.. but still its not detected properly.

Actually, i just realized that my old Seagate ST31000524AS [1TB] disk is SATA III. I had been running it on SATA II port all this time :eek:  :p  without any issues.
just noticed it when i checked in AIDA 64.

I connected the new Hard disk to SATA II port and checked S.M.A.R.T. tests in AIDA64:
It failed almost all of them; sometimes only some of the results are displayed; sometime no results; sometime few attributes repeat.
S.M.A.R.T. Screenshots below:







Please suggest if i should go ahead with SeaTools..

Thanks.
m
0
l
July 29, 2013 8:49:07 AM

cin19 said:
For HDD the performance will be the same between intel and marvel port. The problem is that 1TB HDD only showed 128GB capacity.


In fact, my new Hard Disk ST2000DM001 is 2TB.
My old hard disk ST31000524AS is 1TB, but i never had any such issues in the first place. I was detected correctly right away. Even the BIOS was very old when i installed it (version 0502).
m
0
l
July 29, 2013 12:38:36 PM

@cin19,

Went ahead and checked with SeaTools anyway.

The hard disk failed the "Short Test" right away (yup immediately after i click the button) and obviously the "Long Test" too.
SeaTools test/Failure Code: B3A7964B

Screenshots below:




My old hard disk passes without any issues.

Also the "Set Capacity to MAX Native" will open up the Manual dialog box, maybe since its unable to read the original Hard Disk size from the device.

:( 
m
0
l
August 13, 2013 7:33:44 PM

Hi thunderbolt36!

I'm having exactly the same problem and can't find an answer anywhere. I am also trying to find help in the Seagate forums.

Might I ask, did you find a solution?

Thanks!
m
0
l
a c 971 G Storage
a b Ĉ ASUS
August 14, 2013 3:12:39 PM

If the drive fails seagates seatools utility, the drive needs to be returned or replaced.
m
0
l
Related resources
!