Sign in with
Sign up | Sign in
Your question

Dell wont turn on

Last response: in Systems
Share
July 28, 2013 6:58:20 PM

Hello,

I have a Dell Inspiron 546 that wouldn't turn on. When it is plugged in, a green light lights up on the power supply and an amber light on the mobo. No other lights, and when you press the power button nothing happens, not a fan or anything spins.

I swapped out the power supply BUT the new power supply has 20 pins and the old one has 24 pins...when I connect the main wire with 20 pins the computer will turn on...if I plug both the 4 pin connector and the 20 nothing happens

I did get the computer to turn on with just the 20 pin, however nothing else happens it just starts and the monitor stays black it will not boot. The power button on the front just stays an amber as if it's idle.

I don't really know where to go from here, other than getting the proper power supply and see if that does anything.

Any suggestions?

Sorry if this post is a bit confusing

Thanks!

More about : dell wont turn

July 28, 2013 7:10:27 PM

It isnt that confusing. If you plug the 20 pin connector in, and the plus 4 pin connector (with the little arrow pointing sideways?) in as well, you get nothing?
m
0
l
July 28, 2013 7:13:36 PM

Have you plugged the cpu power lead in beside the heat sink?
m
0
l
Related resources
July 29, 2013 7:39:55 PM

chriss000 said:
It isnt that confusing. If you plug the 20 pin connector in, and the plus 4 pin connector (with the little arrow pointing sideways?) in as well, you get nothing?


Exactly, I get nothing. However, if I unplug the 4 pin it will turn on... but the screen is black and the front power button is amber.

I just double checked it to make sure everything is together properly (including the cpu power lead) and it is. Also, this new power supply works in another computer.
m
0
l
July 30, 2013 5:48:11 PM

Well it's not the power supply like I originally thought. Both PSUs do the same exact thing. I went through the list here on the Forum and I think everything is OK-certain things like standoffs for the motherboard I'm sure aren't the problem, or else it would have been a problem years ago.

I'm stuck. All the hardware is out of the computer except the PSU and the processor-still nothing. What would be the next step?
m
0
l
!