Solved

Monitor is not working after new graphics card

i bought a new graphics card sapphire hd 7950 boost 3gb edition,
i have integrated intel hd 4000, after i installed my new gfx card today my monitor is not working....
i tried connecting my tv with hdmi port in the mobo but then also no display..
then i plugged my hdmi port on my graphics card and it is working fine

that is how im writing this post right new, any idea how to fix my monitor problem

my montor has 1280 X 1024 display and uses a blue switch(i think it might be vga switch)

should i disable my integrated gpu to work(and if how to disable in gigabyte bios)

now my display adapters is showing only AMD hd 7900 and not Intel hd 4000

i have installed updated drivers directly from amd site

my specs
i5 3570k
gigabyte ga z77mx d3h
psu-corsair cx 600
g-skill ripgjawx 8gb ram
7 answers Last reply Best Answer
More about monitor working graphics card
  1. Best answer
    With the discrete card installed the outputs on the card is what you use not the ones on the motherboard which only displays from the IGP.
  2. rolli59 said:
    With the discrete card installed the outputs on the card is what you use not the ones on the motherboard which only displays from the IGP.


    didn't quite understood what you said
  3. should i buy dvi to vga connector in order to run my monitor
  4. Yes since the card can only display through its own ports, not the motherboard ports.
  5. rolli59 said:
    Yes since the card can only display through its own ports, not the motherboard ports.


    should i disable my intel graphics from bios since i have a good gpu so that my processor uses less energy

    please im very new to these things
    how can i disable my intel graphics from gigabyte uefi bios
  6. kratosbellic said:
    rolli59 said:
    Yes since the card can only display through its own ports, not the motherboard ports.


    should i disable my intel graphics from bios since i have a good gpu so that my processor uses less energy

    please im very new to these things
    how can i disable my intel graphics from gigabyte uefi bios

    I believe it is automatically disabled when you installed the card since you did not get any display when you had your monitor on the board connection. It is default on most modern boards to do that.
  7. kratosbellic said:
    i bought a new graphics card sapphire hd 7950 boost 3gb edition,
    i have integrated intel hd 4000, after i installed my new gfx card today my monitor is not working....
    i tried connecting my tv with hdmi port in the mobo but then also no display..
    then i plugged my hdmi port on my graphics card and it is working fine

    that is how im writing this post right new, any idea how to fix my monitor problem

    my montor has 1280 X 1024 display and uses a blue switch(i think it might be vga switch)

    should i disable my integrated gpu to work(and if how to disable in gigabyte bios)

    now my display adapters is showing only AMD hd 7900 and not Intel hd 4000

    i have installed updated drivers directly from amd site

    my specs
    i5 3570k
    gigabyte ga z77mx d3h
    psu-corsair cx 600
    g-skill ripgjawx 8gb ram


    Hello , I had this problem with the same Graphics card.
    I fixed it , this might help you.
    First Use The on-board VGA display mode and Update your BIOS.
    Then Use the Graphics card as the display adaptor so that your card gets the Minimum PSU and Software boost.
    This might help you fixing it. UPDATE YOUR BIOS
Ask a new question

Read More

Graphics Cards Monitors CPUs