Pc won't boot after dust cleaning using a compressed air.

My motherboard is Asus PBH61-M LX Rev 1.00,
The psu is good, and I tested it with multimeter and all the voltages were fine, and I also tried three diffrent power supply units,
There is a green led on the motherboard when there is power.
I tried to remove the cables and replugging them,
I tried to remove all sata connections and all their power cables to the hdd and DVD.

The pc boot itself couple of times when the hdd and the dvd were unplug and its started the bios.
4 answers Last reply
More about boot dust cleaning compressed air
  1. Well if it was booting up without the HDD/DVD then you clearly have a problem with them. Have you plugged them back into the ports you put them in BEFORE you cleaned your PC.
  2. Azrael47 said:
    Well if it was booting up without the HDD/DVD then you clearly have a problem with them. Have you plugged them back into the ports you put them in BEFORE you cleaned your PC.


    I connected them back to the same ports they were, and the pc won't start,
    So I tried to put them on the other ports that I wasn't use and the pc won't start, i tried without them to power the pc and it boot to bios,
    So I shutdown the pc to connect back the hdd (without the DVD), and it don't start up, so I tried again to boot without any thing attached to the motherboard and its wont start even not to bios.
  3. It seems you need to configure your drives in the Bios

    http://computer.howstuffworks.com/bios3.htm
  4. Azrael47 said:
    It seems you need to configure your drives in the Bios

    http://computer.howstuffworks.com/bios3.htm



    I can't get access to the bios, it won't start....
Ask a new question

Read More

Motherboards