Sign in with
Sign up | Sign in
Your question
Solved

After ASRock BIOS Update (2.90) I can't boot from my SSD!

Last response: in Motherboards
Share
August 1, 2013 6:02:43 PM

Hi there,

I take great care of my PC and was recently doing a maintenance session (updating a few programs, clearing space on my SSD, etc) and when it came to updating my BIOS - which I hadn't done since building the PC about 8 months ago - it didn't go well.

I have an ASRock Extreme4 z77 mobo, which has been running BIOS version 2.80 I think since the build. I downloaded the latest BIOS from the ASRock website and ran the program which appeared to work fine then prompted me to restart.

Upon restart it got the error:


'Windows failed to start, possible software update caused this, etc, etc.

Status: 0xc000000f
Info: the boot selection failed because a required device is inaccessible.'


I thought: no problem! The new BIOS has probably forgotten my boot priority order, so went into the Boot Menu and the only 3 options are:

1. AHCI P0: Hitachi HDS721010DLE63 (my HDD)
2. AHCI P1: TSSTCorp DVD +/- RW TS-H (my CD drive, which currently has my Windows 7 disk in)
3. UEFI: TSSTCorp DVD +/- RW TS-H653B (my CD drive again I assume).

I have the Windows disk in the CD drive to try and run Repair as the initial error message suggested, but having successfully booted from the disk it says the version of Restore does not match the type of Windows I am running (it is an OEM, would that matter?).


I'm kicking myself as upon closer inspection I realised that updating my BIOS was completely bloody unnecessary, and the ASRock driver site actually has a message that I missed which suggests that if everything works smoothly (as it was) then don't update.
What I don't understand is why the BIOS update appears to have actually worked fine, then just screwed up my PC's ability to read the SSD...

I have been reading about 'resetting' the Motherboard by taking out the battery and shorting it, but seeing as I can access the BIOS unlike some people after doing this, I hope you guys can think of a better solution.

Any help would be really appreciated. I can post other hardware if needed, although the problem seems pretty darn obviously related to my stupidity in thinking a mobo needed driver updates just like everything else!

Thanks a bunch,
Gosu.

Best solution

a b V Motherboard
August 1, 2013 6:12:14 PM

Go into BIOS & in sata config select AHCI mode & reboot.
Share
August 2, 2013 5:20:44 AM

I WORKED OUT MY PROBLEM:

OK guys I hate when you find a person with similar issues and then they never post if/how they fixed it so here it is:

Updating my BIOS obviously reset my BIOS settings, including having to fiddle a bit for my motherboard to find my SSD. I went back into BIOS after posting and started clicking random options to see if I could figure it out. The solution lay in the option 'Hard Drive BBS Priorities', a file-looking thing just under where I was supposed to choose Boot order.

I went in here, and this allowed me to allocate my SSD as an AHCI option (it was just in the list below HDD and CD Drive). I then returned to the Boot Menu and set my SSD as top priority and it loaded Windows first time.

Thanks for the help beersaway, I had in fact found the answer by the time I saw your message!


Gosu.
m
0
l
Related resources
August 3, 2013 8:47:49 PM

Does the Asrock Changed back to 555 xfast new 2.90 instead of shaded greeny asrock logos in 2.80?

m
0
l
August 10, 2013 10:02:17 AM

"Does the Asrock Changed back to 555 xfast new 2.90 instead of shaded greeny asrock logos in 2.80?"

Nope, same green symbol on startup
m
0
l
!