Solved

New 7870 with old Crt no windows login screen

I recently purchased a Powercolor PCS 7870 to replace my 5750. After I installed the new card, I see the bios screen and the windows logo, however when it finishes loading I get a blank screen. The monitor still shows a green power light and it looks like I am looking at a black picture.

System specs:
Windows 8 64 bit
MSI Z77A-G43 mobo
8 gb of patriot viper ram
500 watt thermatake psu
Old 19" CRT
Core i5 3570k not OC yet
3 answers Last reply Best Answer
More about 7870 crt windows login screen
  1. It could be booting with resolution too high for the monitor.

    Try tapping F8 on boot and selecting safe 640x480 graphics mode on boot.

    If that fails, go into safemode, remove drivers then reinstall in normal mode.
  2. smeezekitty said:
    It could be booting with resolution too high for the monitor.

    Try tapping F8 on boot and selecting safe 640x480 graphics mode on boot.

    If that fails, go into safemode, remove drivers then reinstall in normal mode.


    I tried that and to no avail. I even tried connecting it to my HDTV, but it still would not give me the windows login screen.
    Could it be that there is damage to either the card or the PCI 3.0 slot on the motherboard?

    Edit
    I put the 7870 into the PCI 2 slot and it all works like a dream. Should I RMA the motherboard?
  3. Best answer
    I know I am late here, but I have read that that particular card has a fault in it that causes black screens. Might have to RMA the card or get a different one.
Ask a new question

Read More

Windows Login PowerColor CRT Monitors Graphics