Sign in with
Sign up | Sign in
Your question
Solved

New 7870 with old Crt no windows login screen

Last response: in Graphics & Displays
Share
August 1, 2013 8:46:44 PM

I recently purchased a Powercolor PCS 7870 to replace my 5750. After I installed the new card, I see the bios screen and the windows logo, however when it finishes loading I get a blank screen. The monitor still shows a green power light and it looks like I am looking at a black picture.

System specs:
Windows 8 64 bit
MSI Z77A-G43 mobo
8 gb of patriot viper ram
500 watt thermatake psu
Old 19" CRT
Core i5 3570k not OC yet
August 1, 2013 9:08:00 PM

It could be booting with resolution too high for the monitor.

Try tapping F8 on boot and selecting safe 640x480 graphics mode on boot.

If that fails, go into safemode, remove drivers then reinstall in normal mode.
m
0
l
August 2, 2013 8:14:35 PM

smeezekitty said:
It could be booting with resolution too high for the monitor.

Try tapping F8 on boot and selecting safe 640x480 graphics mode on boot.

If that fails, go into safemode, remove drivers then reinstall in normal mode.


I tried that and to no avail. I even tried connecting it to my HDTV, but it still would not give me the windows login screen.
Could it be that there is damage to either the card or the PCI 3.0 slot on the motherboard?

Edit
I put the 7870 into the PCI 2 slot and it all works like a dream. Should I RMA the motherboard?
m
0
l

Best solution

September 20, 2013 2:22:34 AM

I know I am late here, but I have read that that particular card has a fault in it that causes black screens. Might have to RMA the card or get a different one.
Share
!