Sign in with
Sign up | Sign in
Your question

Asus m5a97 LE R2.0 did turn on once but now only turns on for a second

Last response: in Motherboards
Share
August 1, 2013 9:05:56 PM

I purchased all of my parts and everything and just received them. this is my first build so I was watching a YouTube video on how to build a computer with all of the parts. So i put the CPU, the memory, and the GPU on the board and plug in the main power for the board, the CPU and the GPU and turn on my power supply and it works just fine all the fans were running on my GPU and my CPU. I had the HDMI cord plugged into my monitor but wasn't getting a signal.
So i inspected everything and realize the one edge of my GPU isn't all the way in the slot so i just pushed it in hardly and got a tiny spark. I didn't know what happened so i flipped the switch on my psu and restarted the whole process but this time the fans would only start up for a second and then just immediately die and i dont get anything from the board.
I'm hoping i didn't destroy my board just because i barely pushed in the GPU when it was powered on but I don't really know what to do, if i should just put it in my board and see if it works or just get a whole new board? Help please.


More about : asus m5a97 turn turns

Related resources
a c 645 Ĉ ASUS
a c 1284 V Motherboard
August 1, 2013 10:39:46 PM

If minor, just get the install corrected and good to go
August 1, 2013 10:56:58 PM

ya I took off the little battery, checked CPU, checked all the cords, took out the ram and tried to start it with and without the ram but when i turned on the power supply and tapped the power pins with a screwdriver, the gpu and cpu fans just went for like a second without anything else happening. I didn't get anything on my monitor either.
August 2, 2013 8:35:03 AM

Tradesman1 said:
If minor, just get the install corrected and good to go

i installed everything correctly but when i tap power with the screwdriver, my fans go for a second hardly then just shut off

!