Sign in with
Sign up | Sign in
Your question

Asus Rampage IV Bios Flashed now PC wont start! Help

Last response: in Motherboards
Share
August 2, 2013 5:55:06 PM

I think I flashed my bios but now PC wont start. Removed bios battery for 20 minutes but still no result what should I do?

My Motherboard is Asus Rampage Extreme iv. there is choice of 2 methods for flashing; fast USB method and Ez Flash 2 method. I tried both as per instructions on asus site but neither worked and I'm not sure why so i tried somthing a little different which broke my PC.

Here's what I did: I put both a .cab and .ROM bios files both on my usb stick and switched off PC. (I just copied the CAB file and then changed the file extension to .ROM). USB was inserted into white USB slot at rear of PC. Pressed the button with the Chain icon (not the circle arrow icon) and held it for three seconds untill it started to blink. I waited until blinking was over (about 5-10 min) and booted. Boot failed no errors. fans all start then fans all stop and the cycle continues infinately.

Please help :( 

More about : asus rampage bios flashed wont start

a b Ĉ ASUS
a b V Motherboard
August 2, 2013 7:12:15 PM

deadpixel1 said:
I think I flashed my bios but now PC wont start. Removed bios battery for 20 minutes but still no result what should I do?

My Motherboard is Asus Rampage Extreme iv. there is choice of 2 methods for flashing; fast USB method and Ez Flash 2 method. I tried both as per instructions on asus site but neither worked and I'm not sure why so i tried somthing a little different which broke my PC.

Here's what I did: I put both a .cab and .ROM bios files both on my usb stick and switched off PC. (I just copied the CAB file and then changed the file extension to .ROM). USB was inserted into white USB slot at rear of PC. Pressed the button with the Chain icon (not the circle arrow icon) and held it for three seconds untill it started to blink. I waited until blinking was over (about 5-10 min) and booted. Boot failed no errors. fans all start then fans all stop and the cycle continues infinately.

Please help :( 


try flashing it again , if it does not work then
I am sorry to say that you will need to send the mobo to Asus to reprogram the flash ... maybe your flash is bricked .
m
0
l
Related resources
August 4, 2013 8:27:31 AM

SNA3 said:
hello :

Follow this guide and try your best

http://hardforum.com/showthread.php?t=1726429

have a nice day

But these instructions say, "Do not use reflash command on Z77 and X79 boards with latest BIOSes, it can brick your board, if new ASUS BIOS region protection kicks in. Try biosrefl first and see if it works!"
The Asus rampage iv extreme is an X79 board so I guess this isnt worth a shot?. I'm not sure what bios refl is? To be honest I feel this solution is a little over my head.
m
0
l
August 4, 2013 10:05:39 AM

Update: since my mobo is dual bios i swapped over the two bioses and now my comp works! Lucky. Anyway I guess i'm now running off the spare bios right? So I want to know how i can fix the bricked bios?

PS why do I have a spare bios with this mobo?
m
0
l
a b Ĉ ASUS
a b V Motherboard
August 4, 2013 7:27:31 PM

deadpixel1 said:
Update: since my mobo is dual bios i swapped over the two bioses and now my comp works! Lucky. Anyway I guess i'm now running off the spare bios right? So I want to know how i can fix the bricked bios?

PS why do I have a spare bios with this mobo?


lucky :) 

you will need bios programmer to repair the bios.
m
0
l
!