Sign in with
Sign up | Sign in
Your question

Can't renew ip address

Last response: in Windows XP
Share
August 3, 2013 6:27:23 PM

Okay so I have a pc that is running windows Xp sp 2. Everything was working great for several months then all of the sudden Internet stopped working. I am using a Realtek wireless USB adapter to to access Internet from a wireless d link router. Connection says limited or no connectivity when I click repair it says cannot renew IP address. Here is what I have tried.

Switched Realtek adapter with a n300 wireless adapter, same issue.
Ran cmd ipconfig /release /renew
Ran cmd for dns dump
Ran cmd for windsock repairs
Cmd for etch windsock reset catalog
Reset OS to one month prior even though the issue only happened today, as I was online only hours ago.
Deleted network connection and created a new connection
Made sure dhcp is enabled on pc as well as router
Reset everything
Read forums for hours
Other devices are working fine as I am typing this now on an ipad on the same network.
Ran virus / malware scans
Made sure all drivers are up to date

About to pull my hair out.
Ipconfig reads
Ethernet adapter wireless network connection 2:
Connection-specific dns suffix:
Autoconfiguration IP address: 169.254.189.14
Subnet mask: 255.255.0.0
Default gateway:

The router is set up to assign IP addresses that are 192.168.0.10x



Weird thing was that it did actually connect on its own for a split second (didn't show any limited connectivity errors) when I check the connection it said address assigned by dhcp was not able to access anything even though it didn't show anything wrong. When I tried to repair it came back to the cant renew IP address bs and back to limited or no connectivity.

Sorry for the rant but I wanted to give as much information as possible. I am not able to check for a wired connection as the modem is next door.

More about : renew address

August 3, 2013 6:34:00 PM

Could you run an "ipconfig/all" and dump it here?
August 3, 2013 6:47:53 PM

I should also add that when running IP renew it gives the error unable to contact your dhcp server. Request timed out.
Related resources
August 3, 2013 6:56:40 PM

Here goes a lot of touch screen typing....

Windows IP configuration:

Host name ..... Pc
Primary dns suffix.......
Node type... Hybrid
IP routing enabled.... No
Wins proxy enabled..... No

Ethernet adapter wireless network connection:

Connection specific dns suffix........
Description... Netgear wna3100 n300 wireless USB adapter
Physical address..... 4c-60-de-7d-5d-9f
Dhcp enabled.... Yes
Auto configuration enabled...... Yes
IP address 0.0.0.0
Subnet mask 0.0.0.0
Default gateway......
Dhcp server.... 255.255.255.255
August 4, 2013 12:05:18 PM

I was actually able to connect last night, not sure why but it let me. This morning when I turned pc back on I am having the same issue. The computer connected automatically last night. The n300 adapter has a separate interface other than the windows one and it is still showing being connected to the router itself but there is a red x between the router and the Internet. Yet other devices are still having no issues. I hadn't tampered with anything so it all seems a bit strange that this problem would pop up out of nowhere.



Update: this worked today, running cmd ipconfig release and then unplugging the adapter and plugging it back in, not sure if this is the issue but I have Internet right now so I'm not about to unplug it again. Will update later. There's got to be something else going on.
!