Active Directory Users and Computers

When trying to open Active Directory Users and Computers it will say "mmc could not create the snap-in"

This is on windows 7 computer joined to a domain.
4 answers Last reply
More about active directory users computers
  1. I had that happen on one system previously. Not sure if the solution I came up with was the actual solution, or if it just corrected itself but I did the following and it worked again...

    Before doing ANY work at all, perform a FULL backup of the system and its data directories!

    #1. Remove the system from the AD / make it a stand alone box.
    #2. Patch the system fully up to date, including update AV, and Anti Malware.
    #3. Run full scan AV, and Malware. The client box I was working on had a DNS issue due to a piece of malware that did get cleaned off. If you have a persistent virus / malware that you just can NOT get to scan clean, or if you just don't trust that all the threats were removed wipe and re load the box.
    #4. Re join domain.

    Good luck!
  2. I just tried removing & re-joining it to the domain but it still does the same.
  3. Did you run AV / Malware scan, or just remove / re-add?
  4. It may sound silly but the Net Admin looked at it and installed features that fixed it. I had went through and checked everything I could possibly find, even dhcp management stuff.
Ask a new question

Read More

Computers Networking Active Directory