Sign in with
Sign up | Sign in
Your question
Solved

SOLVED: Razer Megalodon Not Recognised

Last response: in Home Audio
Share
August 7, 2013 11:38:19 AM

I have recently completed building my new system, and everything seems to work fine except for my razer megaladon headphones. When I plug them in either there is an error saying the usb device is not recognised, or that the usb device has malfunctioned. I have 4 other USB devices that worked perfectly, and have tried plugging the headphones into every socket, aswell as trying without any other devices, the results are still the same.

The headphones worked perfectly well on my old system, and currently work fine with my laptop.

I have updated all motherboard drivers to their latest versions.

I initially tried updating the headphones' firmware on my new desktop, however whilst the device WAS recognised when i plugged it in in upgrade mode (middle button pushed down as you insert it), when running the firmware updater it would fail anywhere between 4% and 80% without ever completing. I finally used my laptop to update the firmware of the headset, which worked perfectly.

The headset is now around 2yrs old, and this is the first problem I have had with it.

If anybody has any suggestions or is also having this problem it would be very helpful to hear from you.

*EDIT*
I would add that the mobo I am using is an asus z87-a
August 7, 2013 8:04:32 PM

So I'm not sure what brand of wizardry was invoked, but when I turned my new computer on this morning, having changed not a thing, my headset miraculously works.

Best solution

August 29, 2013 1:08:30 PM
Share

I have this exact problem. The only difference is an asus hero VI mobo.
Did you leave the headset plugged in when starting up the computer or did you plug it in after restart? Does the computer detect it every time now? Can you think of anything else you did?
I actually think I've had this problem earlier too, but I can't remember how I fixed it.

The only thing I can think of doing now is reinstalling w7, I've been searching for solutions for longer than I like.

Edit: I ended up reinstalling w7 a few times to try to pinpoint the problem. Since it would register immediately after a fresh install and then disappear when installing drivers. The problem appears when installing the usb 3 drivers (makes sense). So what I've ended up doing is just not installing these. The usb ports still work fine, and I have no need for any potential boost I get from installing the usb 3 drivers.
!