Sign in with
Sign up | Sign in
Your question
Solved

amd 6600k integrated graphics

Last response: in CPUs
Share
August 8, 2013 2:17:53 AM

I need help. i just build my system . i have an amd 6600k with integrated radeon 8570D. as motherboard i have asrock fm2a85x extreme4 . i think the integrated graphics is not activated because i have problems : i can't change rezolution above 1280x1024 ( i have fullhd monitor) , when i enter in gpu-z , the porgram don't show me model number and information about integrated gpu and, in right corner ati logo don't appear.
on asrock site i saw this motherboard support 7000 series graphic (trinity) , but my igpu is 8570d ( richland) . Do you think this is the porblem . What can i do ?
August 8, 2013 2:22:59 AM

you may need to go into the BIOS (usually hitting either f2 or del on boot) and change the primary graphics adapter from PCI-e to integrated
a b à CPUs
a b V Motherboard
August 8, 2013 2:25:19 AM

MoonL said:
I need help. i just build my system . i have an amd 6600k with integrated radeon 8570D. as motherboard i have asrock fm2a85x extreme4 . i think the integrated graphics is not activated because i have problems : i can't change rezolution above 1280x1024 ( i have fullhd monitor) , when i enter in gpu-z , the porgram don't show me model number and information about integrated gpu and, in right corner ati logo don't appear.
on asrock site i saw this motherboard support 7000 series graphic (trinity) , but my igpu is 8570d ( richland) . Do you think this is the porblem . What can i do ?


Install the drivers

http://www.asrock.com/mb/AMD/FM2A85X%20Extreme4/?cat=Do...

Related resources
a b À AMD
a c 85 à CPUs
a b V Motherboard
August 8, 2013 2:25:42 AM

Did you install all the drivers from the motherboard CD? A8-6600k is listed as a supported CPU on the site for the motherboard so shouldn't be a problem and the fact that you get video and can't set it higher says no drivers.
August 8, 2013 3:18:05 AM

SNA3 said:
MoonL said:
I need help. i just build my system . i have an amd 6600k with integrated radeon 8570D. as motherboard i have asrock fm2a85x extreme4 . i think the integrated graphics is not activated because i have problems : i can't change rezolution above 1280x1024 ( i have fullhd monitor) , when i enter in gpu-z , the porgram don't show me model number and information about integrated gpu and, in right corner ati logo don't appear.
on asrock site i saw this motherboard support 7000 series graphic (trinity) , but my igpu is 8570d ( richland) . Do you think this is the porblem . What can i do ?


Install the drivers

http://www.asrock.com/mb/AMD/FM2A85X%20Extreme4/?cat=Do...



I think , i must update the bios to support richland cpu with 8000 series graphics . I will do this operation and tell you latter if this worked

Best solution

a b À AMD
a c 85 à CPUs
a b V Motherboard
August 8, 2013 3:25:59 AM
Share

You still haven't said if you installed the drivers.

that CPU was supported since BIOS P1.40, so reboot and check your BIOS screen to see if you are at 1.4 or above?
August 8, 2013 3:28:41 AM

getochkn said:
You still haven't said if you installed the drivers.

that CPU was supported since BIOS P1.40, so reboot and check your BIOS screen to see if you are at 1.4 or above?


I've checked the bios . I have 1.2 version
I think this is the problem . What do you say ?

a b à CPUs
a b V Motherboard
August 8, 2013 3:32:14 AM

MoonL said:
getochkn said:
You still haven't said if you installed the drivers.

that CPU was supported since BIOS P1.40, so reboot and check your BIOS screen to see if you are at 1.4 or above?


I've checked the bios . I have 1.2 version
I think this is the problem . What do you say ?



http://www.asrock.com/mb/AMD/FM2A85X%20Extreme4/?cat=CP...

update the bios
August 8, 2013 4:20:33 AM

SNA3 said:
MoonL said:
getochkn said:
You still haven't said if you installed the drivers.

that CPU was supported since BIOS P1.40, so reboot and check your BIOS screen to see if you are at 1.4 or above?


I've checked the bios . I have 1.2 version
I think this is the problem . What do you say ?



http://www.asrock.com/mb/AMD/FM2A85X%20Extreme4/?cat=CP...

update the bios

I updated the bios . The rezolution problem is solved. I will install the windows and drivers again .

a b À AMD
a c 85 à CPUs
a b V Motherboard
August 8, 2013 4:39:37 AM

MoonL said:
SNA3 said:
MoonL said:
getochkn said:
You still haven't said if you installed the drivers.

that CPU was supported since BIOS P1.40, so reboot and check your BIOS screen to see if you are at 1.4 or above?


I've checked the bios . I have 1.2 version
I think this is the problem . What do you say ?



http://www.asrock.com/mb/AMD/FM2A85X%20Extreme4/?cat=CP...

update the bios

I updated the bios . The rezolution problem is solved. I will install the windows and drivers again .



Shouldn't have to do a full wipe, but if you have nothing on the Windows yet, guess it won't hurt. lol.

Don't forgot to mark it as solved and pick a best answer.
!